summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-07-08 10:32:21 +0000
committerPeter Volkov <pva@gentoo.org>2009-07-08 10:32:21 +0000
commita39d62cd8cebbb113f9c83231c58028e69ca1c3b (patch)
treea651cbcd3c94f0fce5a5b88c23c0804c18704d6d /net-analyzer
parentWe don't need inherit/eautoreconf here. Forgot to drop it after work on fix w... (diff)
downloadgentoo-2-a39d62cd8cebbb113f9c83231c58028e69ca1c3b.tar.gz
gentoo-2-a39d62cd8cebbb113f9c83231c58028e69ca1c3b.tar.bz2
gentoo-2-a39d62cd8cebbb113f9c83231c58028e69ca1c3b.zip
Fixed bug #272767, thank Martin Mokrejš for report and Rafał for investigation. A bit improved nls handling.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog9
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.3.8-configure.ac.patch16
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.3.8-r1.ebuild99
3 files changed, 123 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 64169c01b000..a4abfa024003 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.182 2009/06/01 19:58:42 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.183 2009/07/08 10:32:21 pva Exp $
+
+*rrdtool-1.3.8-r1 (08 Jul 2009)
+
+ 08 Jul 2009; Peter Volkov <pva@gentoo.org>
+ +files/rrdtool-1.3.8-configure.ac.patch, +rrdtool-1.3.8-r1.ebuild:
+ Fixed bug #272767, thank Martin Mokrejš for report and Rafał for
+ investigation. A bit improved nls handling.
01 Jun 2009; Peter Volkov <pva@gentoo.org> rrdtool-1.3.8.ebuild,
metadata.xml:
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.3.8-configure.ac.patch b/net-analyzer/rrdtool/files/rrdtool-1.3.8-configure.ac.patch
new file mode 100644
index 000000000000..d1c719bd1893
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.3.8-configure.ac.patch
@@ -0,0 +1,16 @@
+=== modified file 'configure.ac'
+--- configure.ac 2009-07-08 09:47:54 +0000
++++ configure.ac 2009-07-08 09:51:00 +0000
+@@ -174,11 +174,6 @@
+ AC_CHECK_FUNC(acos, , AC_CHECK_LIB(m, acos))
+
+
+-dnl add pic flag in any case this makes sure all our code is relocatable
+-eval `./libtool --config | grep pic_flag`
+-CFLAGS="$CFLAGS $pic_flag"
+-
+-
+ dnl Checks for library functions.
+ AC_FUNC_STRFTIME
+ AC_FUNC_VPRINTF
+
diff --git a/net-analyzer/rrdtool/rrdtool-1.3.8-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.3.8-r1.ebuild
new file mode 100644
index 000000000000..9b2d9a3e2e26
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.3.8-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.3.8-r1.ebuild,v 1.1 2009/07/08 10:32:21 pva Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib perl-module autotools
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc nls perl python ruby rrdcgi tcl"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.2.10
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/cairo-1.4.6[svg]
+ >=dev-libs/glib-2.12.12
+ >=x11-libs/pango-1.17
+ nls? ( >=dev-util/intltool-0.35 )
+ tcl? ( dev-lang/tcl )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.8.6_p287-r13
+ !dev-ruby/ruby-rrd )"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk"
+
+pkg_setup() {
+ use perl && perl-module_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/rrdtool-1.3.8-configure.ac.patch"
+ mkdir m4
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=/usr/share/doc/${PF}
+
+ econf $(use_enable rrdcgi) \
+ $(use_enable nls) \
+ $(use_enable nls libintl) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib /usr/$(get_libdir)) \
+ $(use_enable python)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/{html,txt}
+ fi
+
+ use perl && fixlocalpod
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+}
+
+pkg_preinst() {
+ use perl && perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+ ewarn "rrdtool dump 1.3 does emit completely legal xml. Basically this means that"
+ ewarn "it contains an xml header and a DOCTYPE definition. Unfortunately this"
+ ewarn "causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with ann old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+ ewarn
+ ewarn "Note: rrdtool-1.3.x doesn't have any default font bundled. Thus if you've"
+ ewarn "upgraded from rrdtool-1.2.x and don't have any font installed to make"
+ ewarn "lables visible, please, install some font, e.g. media-fonts/dejavu."
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}