summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-20 17:14:12 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-20 17:14:12 +0000
commit7f623bbc73613f3d0bd936a8d6fd5f5acbd9648f (patch)
tree7bac7106d069b755fc1190fbfe2bc972b7d482f4 /net-analyzer
parentEAPI=2; add use-based dep (diff)
downloadgentoo-2-7f623bbc73613f3d0bd936a8d6fd5f5acbd9648f.tar.gz
gentoo-2-7f623bbc73613f3d0bd936a8d6fd5f5acbd9648f.tar.bz2
gentoo-2-7f623bbc73613f3d0bd936a8d6fd5f5acbd9648f.zip
Version bump. Probably the last ever.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/bmon/ChangeLog7
-rw-r--r--net-analyzer/bmon/bmon-2.1.1_pre1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/net-analyzer/bmon/ChangeLog b/net-analyzer/bmon/ChangeLog
index 9f233ab3a61c..0f116b15b461 100644
--- a/net-analyzer/bmon/ChangeLog
+++ b/net-analyzer/bmon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/bmon
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.40 2009/01/20 17:01:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/ChangeLog,v 1.41 2009/01/20 17:14:12 jer Exp $
+
+*bmon-2.1.1_pre1 (20 Jan 2009)
+
+ 20 Jan 2009; Jeroen Roovers <jer@gentoo.org> +bmon-2.1.1_pre1.ebuild:
+ Version bump. Probably the last ever.
20 Jan 2009; Jeroen Roovers <jer@gentoo.org>
files/bmon-2.1.0-libnl-1.0.patch:
diff --git a/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild b/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild
new file mode 100644
index 000000000000..287e3baece48
--- /dev/null
+++ b/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bmon/bmon-2.1.1_pre1.ebuild,v 1.1 2009/01/20 17:14:12 jer Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PV="${PV/_pre/-pre}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="interface bandwidth monitor"
+HOMEPAGE="http://people.suug.ch/~tgr/bmon/"
+SRC_URI="http://people.suug.ch/~tgr/bmon/files/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="dbi rrdtool"
+
+DEPEND=">=sys-libs/ncurses-5.3-r2
+ >=dev-libs/libnl-0.5.0
+ dbi? ( >=dev-db/libdbi-0.7.2-r1 )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.6-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # gcc4 fix, bug 105343
+ epatch "${FILESDIR}"/${PN}-2.1.0-gcc4.diff
+ # Don't strip, bug #144370
+ epatch "${FILESDIR}"/${PN}-2.1.0-nostrip.patch
+ # libnl crap, bug 176378
+ epatch "${FILESDIR}"/${PN}-2.1.0-libnl-1.0.patch
+
+}
+
+src_compile() {
+ econf \
+ $(use_enable dbi) \
+ $(use_enable rrdtool rrd) || die "econf failed"
+ emake CPPFLAGS="${CXXFLAGS} -I${WORKDIR}/libnl-${NLVER}/include" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}