summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-04-05 20:39:17 +0000
committerPeter Volkov <pva@gentoo.org>2009-04-05 20:39:17 +0000
commit7810cd0202bfae428ed2d9e44f215ceec88b4124 (patch)
treea8b07a4ac0f721dfaf23822a8b944ee54380522e /net-analyzer
parentx86 stable, bug #264982 (diff)
downloadgentoo-2-7810cd0202bfae428ed2d9e44f215ceec88b4124.tar.gz
gentoo-2-7810cd0202bfae428ed2d9e44f215ceec88b4124.tar.bz2
gentoo-2-7810cd0202bfae428ed2d9e44f215ceec88b4124.zip
Small rework of getword-boundary-limit.patch, now we issue warning instead of exit(1) in case a limit at getword was not enough to handle word. Add fix for bug #263802, thank cpa for report and Dmitriy Bogun for usefull backtrace.
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sarg/ChangeLog10
-rw-r--r--net-analyzer/sarg/sarg-2.2.5-r2.ebuild79
2 files changed, 88 insertions, 1 deletions
diff --git a/net-analyzer/sarg/ChangeLog b/net-analyzer/sarg/ChangeLog
index e6a97f0ccf43..c5a4d395bc08 100644
--- a/net-analyzer/sarg/ChangeLog
+++ b/net-analyzer/sarg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/sarg
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.47 2009/03/24 18:54:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.48 2009/04/05 20:39:17 pva Exp $
+
+*sarg-2.2.5-r2 (05 Apr 2009)
+
+ 05 Apr 2009; Peter Volkov <pva@gentoo.org> +sarg-2.2.5-r2.ebuild:
+ Small rework of getword-boundary-limit.patch, now we issue warning instead
+ of exit(1) in case a limit at getword was not enough to handle word. Add
+ fix for bug #263802, thank cpa for report and Dmitriy Bogun for usefull
+ backtrace.
24 Mar 2009; Brent Baude <ranger@gentoo.org> sarg-2.2.5-r1.ebuild:
Marking sarg-2.2.5-r1 ppc for bug 222121
diff --git a/net-analyzer/sarg/sarg-2.2.5-r2.ebuild b/net-analyzer/sarg/sarg-2.2.5-r2.ebuild
new file mode 100644
index 000000000000..15516ab96707
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.2.5-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.2.5-r2.ebuild,v 1.1 2009/04/05 20:39:17 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/sarg.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-patchset-2.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-libs/gd[png,truetype]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ EPATCH_SOURCE="${WORKDIR}/patches/" EPATCH_SUFFIX="patch" epatch
+
+ einfo "Running sed to substitute paths..."
+ sed \
+ -e 's:/usr/local/squid/var/logs/access.log:/var/log/squid/access.log:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -e 's:/var/www/html/squid-reports:/var/www/localhost/htdocs/squid-reports:' \
+ -i sarg.conf || die
+
+ sed \
+ -e 's:"/usr/local/squid/var/logs/access.log":"/var/log/squid/access.log":' \
+ -e 's:"/var/www/html/squid-reports":"/var/www/localhost/htdocs/squid-reports":' \
+ -e 's:"/usr/local/sarg/passwd":"/etc/sarg/passwd":' \
+ -i log.c || die #43132
+
+ sed -e 's:/usr/local/sarg/passwd:/etc/sarg/passwd:' \
+ -i htaccess || die
+
+ sed -e 's:/usr/local/squid/logs/access.log:/var/log/squid/access.log:' \
+ -i splitlog.c convlog.c || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/squid/etc/passwd:/etc/squid/passwd:' \
+ -i user_limit_block || die
+
+ sed -e 's:/usr/local/squid/etc/block.txt:/etc/squid/etc/block.txt:' \
+ -i sarg-php/sarg-block-it.php || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -e 's:/usr/local/squid/logs/access.log:/var/log/squid/access.log:' \
+ -i sarg.1 sarg-php/sarg-squidguard-block.php || die
+
+ sed -i -e 's:sarg_tmp:sarg:' email.c || die #64743
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bindir=/usr/bin \
+ --enable-mandir=/usr/share/man/man1 \
+ --enable-sysconfdir=/etc/sarg/
+}
+
+src_install() {
+ # This is workaround for sarg installation script, which does not create dirs
+ dodir /etc/sarg /usr/sbin
+
+ make \
+ BINDIR="${D}"/usr/sbin \
+ MANDIR="${D}"/usr/share/man/man1 \
+ SYSCONFDIR="${D}"/etc/sarg \
+ HTMLDIR="${D}"/var/www/html \
+ install || die "sarg installation failed"
+
+ dodoc BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess
+}