summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-28 08:04:16 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-28 08:04:16 +0000
commit71548e38ce4740fa3813fa392a50f57bb71732a9 (patch)
treeda08fe6512e3b3076084db3da1a5a760ef898e2d /net-analyzer
parentx86 stable wrt bug #366575 (diff)
downloadgentoo-2-71548e38ce4740fa3813fa392a50f57bb71732a9.tar.gz
gentoo-2-71548e38ce4740fa3813fa392a50f57bb71732a9.tar.bz2
gentoo-2-71548e38ce4740fa3813fa392a50f57bb71732a9.zip
Version Bump
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/ChangeLog8
-rw-r--r--net-analyzer/linkchecker/files/7.0-unbundle.patch28
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.0.ebuild81
3 files changed, 116 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 5d20974c3c37..6201d9308381 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.52 2011/05/09 07:47:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.53 2011/05/28 08:04:16 jlec Exp $
+
+*linkchecker-7.0 (28 May 2011)
+
+ 28 May 2011; Justin Lecher <jlec@gentoo.org> +files/7.0-unbundle.patch,
+ +linkchecker-7.0.ebuild:
+ Version Bump
*linkchecker-6.9 (09 May 2011)
diff --git a/net-analyzer/linkchecker/files/7.0-unbundle.patch b/net-analyzer/linkchecker/files/7.0-unbundle.patch
new file mode 100644
index 000000000000..74b9d11c26e9
--- /dev/null
+++ b/net-analyzer/linkchecker/files/7.0-unbundle.patch
@@ -0,0 +1,28 @@
+ setup.py | 7 -------
+ 1 files changed, 0 insertions(+), 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8eace2a..e6aaf68 100644
+--- a/setup.py
++++ b/setup.py
+@@ -754,9 +754,6 @@ o a (Fast)CGI web interface (requires HTTP server)
+ 'py2app': MyPy2app,
+ 'register': MyRegister,
+ },
+- package_dir = {
+- 'dns': 'third_party/dnspython/dns',
+- },
+ packages = [
+ 'linkcheck',
+ 'linkcheck.bookmarks',
+@@ -769,10 +766,6 @@ o a (Fast)CGI web interface (requires HTTP server)
+ 'linkcheck.HtmlParser',
+ 'linkcheck.logger',
+ 'linkcheck.network',
+- 'dns',
+- 'dns.rdtypes',
+- 'dns.rdtypes.ANY',
+- 'dns.rdtypes.IN',
+ ],
+ ext_modules = [
+ Extension('linkcheck.HtmlParser.htmlsax',
diff --git a/net-analyzer/linkchecker/linkchecker-7.0.ebuild b/net-analyzer/linkchecker/linkchecker-7.0.ebuild
new file mode 100644
index 000000000000..8ede3e1ff98f
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.0.ebuild,v 1.1 2011/05/28 08:04:16 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND=""
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/5.2-missing-files.patch \
+ "${FILESDIR}"/${PV}-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ delete_gui() {
+ if ! use X; then
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ fi
+ }
+ python_execute_function -q delete_gui
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+ use bash-completion && dobashcompletion config/linkchecker-completion
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ echo ""
+ distutils_pkg_postinst
+}