summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-15 08:55:03 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-15 08:55:03 +0000
commit64f6a17d9e13523778b9371308a05d981111ce15 (patch)
treec064b076df52c34a7b85079e360ae6594efcc381 /net-analyzer
parentFix typo (#513296) (diff)
downloadgentoo-2-64f6a17d9e13523778b9371308a05d981111ce15.tar.gz
gentoo-2-64f6a17d9e13523778b9371308a05d981111ce15.tar.bz2
gentoo-2-64f6a17d9e13523778b9371308a05d981111ce15.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nb/ChangeLog9
-rw-r--r--net-analyzer/nb/nb-0.8.17.ebuild59
-rw-r--r--net-analyzer/nb/nb-0.9.02.ebuild59
3 files changed, 126 insertions, 1 deletions
diff --git a/net-analyzer/nb/ChangeLog b/net-analyzer/nb/ChangeLog
index 66217b1c7bbf..f66c96002d51 100644
--- a/net-analyzer/nb/ChangeLog
+++ b/net-analyzer/nb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/nb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/ChangeLog,v 1.20 2014/07/14 12:15:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/ChangeLog,v 1.21 2014/08/15 08:55:03 jer Exp $
+
+*nb-0.9.02 (15 Aug 2014)
+*nb-0.8.17 (15 Aug 2014)
+
+ 15 Aug 2014; Jeroen Roovers <jer@gentoo.org> +nb-0.8.17.ebuild,
+ +nb-0.9.02.ebuild:
+ Version bump.
14 Jul 2014; Jeroen Roovers <jer@gentoo.org> -nb-0.8.14.ebuild,
-files/nb-0.8.14-configure.patch:
diff --git a/net-analyzer/nb/nb-0.8.17.ebuild b/net-analyzer/nb/nb-0.8.17.ebuild
new file mode 100644
index 000000000000..80540000da2f
--- /dev/null
+++ b/net-analyzer/nb/nb-0.8.17.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/nb-0.8.17.ebuild,v 1.1 2014/08/15 08:55:03 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+
+S="${WORKDIR}/nodebrain-${PV}"
+
+src_prepare() {
+ # fdl.texi is not included in the sources
+ sed -i \
+ -e '/@include fdl.texi/d' \
+ doc/nbTutorial/nbTutorial.texi || die
+
+ epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_compile() {
+ # Fails at parallel make
+ emake -j1
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}
diff --git a/net-analyzer/nb/nb-0.9.02.ebuild b/net-analyzer/nb/nb-0.9.02.ebuild
new file mode 100644
index 000000000000..ad9d5e71d2b7
--- /dev/null
+++ b/net-analyzer/nb/nb-0.9.02.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/nb-0.9.02.ebuild,v 1.1 2014/08/15 08:55:03 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+
+S="${WORKDIR}/nodebrain-${PV}"
+
+src_prepare() {
+ # fdl.texi is not included in the sources
+ sed -i \
+ -e '/@include fdl.texi/d' \
+ doc/nbTutorial/nbTutorial.texi || die
+
+ epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_compile() {
+ # Fails at parallel make
+ emake -j1
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}