summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-07-24 11:49:19 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-07-24 11:49:19 +0000
commit2129f96babf722d018d6e3391dac1ff220bcbbde (patch)
tree64a9043576c49dab7416d5ab6b1c52481c8a9b20 /net-analyzer/zabbix
parentVersion bump for bug #184290. (diff)
downloadgentoo-2-2129f96babf722d018d6e3391dac1ff220bcbbde.tar.gz
gentoo-2-2129f96babf722d018d6e3391dac1ff220bcbbde.tar.bz2
gentoo-2-2129f96babf722d018d6e3391dac1ff220bcbbde.zip
version bump
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'net-analyzer/zabbix')
-rw-r--r--net-analyzer/zabbix/ChangeLog11
-rw-r--r--net-analyzer/zabbix/files/1.4.1/init.d/zabbix-agentd22
-rw-r--r--net-analyzer/zabbix/files/1.4.1/init.d/zabbix-server21
-rw-r--r--net-analyzer/zabbix/files/1.4.1/postinstall-en.txt8
-rw-r--r--net-analyzer/zabbix/files/1.4.1/zabbix_agent.conf25
-rw-r--r--net-analyzer/zabbix/files/1.4.1/zabbix_agentd.conf70
-rw-r--r--net-analyzer/zabbix/files/1.4.1/zabbix_server.conf98
-rw-r--r--net-analyzer/zabbix/files/digest-zabbix-1.4.13
-rw-r--r--net-analyzer/zabbix/zabbix-1.4.1.ebuild264
9 files changed, 521 insertions, 1 deletions
diff --git a/net-analyzer/zabbix/ChangeLog b/net-analyzer/zabbix/ChangeLog
index cd1bd62177e1..f8566275eccc 100644
--- a/net-analyzer/zabbix/ChangeLog
+++ b/net-analyzer/zabbix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/zabbix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.1 2007/06/08 01:41:21 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/ChangeLog,v 1.2 2007/07/24 11:49:19 wschlich Exp $
+
+*zabbix-1.4.1 (24 Jul 2007)
+
+ 24 Jul 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/1.4.1/init.d/zabbix-agentd, +files/1.4.1/init.d/zabbix-server,
+ +files/1.4.1/postinstall-en.txt, +files/1.4.1/zabbix_agent.conf,
+ +files/1.4.1/zabbix_agentd.conf, +files/1.4.1/zabbix_server.conf,
+ +zabbix-1.4.1.ebuild:
+ version bump
*zabbix-1.4 (08 Jun 2007)
diff --git a/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-agentd b/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-agentd
new file mode 100644
index 000000000000..c742a5a82a50
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-agentd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-agentd,v 1.1 2007/07/24 11:49:19 wschlich Exp $
+
+depend() {
+ need net
+ provide zabbix-agent
+ use zabbix-server
+}
+
+start() {
+ ebegin "Starting Zabbix agent"
+ start-stop-daemon --start -c zabbix:zabbix --exec /usr/sbin/zabbix_agentd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Zabbix agent"
+ start-stop-daemon --stop -u zabbix --pidfile /var/run/zabbix/zabbix_agentd.pid
+ eend $?
+}
diff --git a/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-server b/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-server
new file mode 100644
index 000000000000..e538523efaa0
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-server
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/files/1.4.1/init.d/zabbix-server,v 1.1 2007/07/24 11:49:19 wschlich Exp $
+
+depend() {
+ need net
+ use mysql postgresql
+}
+
+start() {
+ ebegin "Starting Zabbix server"
+ start-stop-daemon --start -c zabbix:zabbix --exec /usr/sbin/zabbix_server
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Zabbix server"
+ start-stop-daemon --stop -u zabbix --pidfile /var/run/zabbix/zabbix_server.pid
+ eend $?
+}
diff --git a/net-analyzer/zabbix/files/1.4.1/postinstall-en.txt b/net-analyzer/zabbix/files/1.4.1/postinstall-en.txt
new file mode 100644
index 000000000000..9d13a9f3dbce
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/postinstall-en.txt
@@ -0,0 +1,8 @@
+Please change the values of the following variables in
+${MY_HTDOCSDIR}/include/db.inc.php:
+
+ DB_TYPE
+ DB_SERVER
+ DB_DATABASE
+ DB_USER
+ DB_PASSWORD
diff --git a/net-analyzer/zabbix/files/1.4.1/zabbix_agent.conf b/net-analyzer/zabbix/files/1.4.1/zabbix_agent.conf
new file mode 100644
index 000000000000..42997388900e
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/zabbix_agent.conf
@@ -0,0 +1,25 @@
+# This is config file for zabbix_agent
+# To get more information about ZABBIX,
+# go http://www.zabbix.com
+
+# IP address of ZABBIX server
+# Connections from other hosts will be denied
+Server=127.0.0.1
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix/files/1.4.1/zabbix_agentd.conf b/net-analyzer/zabbix/files/1.4.1/zabbix_agentd.conf
new file mode 100644
index 000000000000..e040f17efcc9
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/zabbix_agentd.conf
@@ -0,0 +1,70 @@
+# This is config file for zabbix_agentd
+# To get more information about ZABBIX, go http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+# List of comma delimited IP addresses (or hostnames) of ZABBIX servers.
+# No spaces allowed. First entry is used for sending active checks.
+# Note that hostnames must resolve hostname->IP address and
+# IP address->hostname.
+Server=127.0.0.1
+
+# Server port for sending active checks
+ServerPort=10051
+
+# Unique hostname. Required for active checks.
+Hostname=localhost
+
+# Listen port. Default is 10050
+ListenPort=10050
+
+# IP address to bind agent
+# If missing, bind to all available IPs
+ListenIP=127.0.0.1
+
+# Number of pre-forked instances of zabbix_agentd.
+# Default value is 5
+# This parameter must be between 1 and 16
+StartAgents=5
+
+# How often refresh list of active checks. 2 minutes by default.
+#RefreshActiveChecks=120
+
+# Disable active checks. The agent will work in passive mode listening server.
+#DisableActive=1
+
+# Enable remote commands for ZABBIX agent. By default remote commands disabled.
+#EnableRemoteCommands=1
+
+# Specifies debug level
+# 0 - debug is not created
+# 1 - critical information
+# 2 - error information
+# 3 - warnings (default)
+# 4 - for debugging (produces lots of information)
+DebugLevel=3
+
+# Name of PID file
+PidFile=/var/run/zabbix/zabbix_agentd.pid
+
+# Name of log file.
+# If not set, syslog will be used
+LogFile=/var/log/zabbix/zabbix_agentd.log
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix/files/1.4.1/zabbix_server.conf b/net-analyzer/zabbix/files/1.4.1/zabbix_server.conf
new file mode 100644
index 000000000000..12490f881130
--- /dev/null
+++ b/net-analyzer/zabbix/files/1.4.1/zabbix_server.conf
@@ -0,0 +1,98 @@
+# This is config file for ZABBIX server process
+# To get more information about ZABBIX,
+# go http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+# This defines which server this is.
+# Default value 1
+# This parameter must be between 1 and 255
+Server=1
+
+# Number of pre-forked instances of pollers
+# Default value is 6
+# This parameter must be between 6 and 255
+StartPollers=6
+
+# Number of pre-forked instances of trappers
+# Default value is 5
+# This parameter must be between 2 and 255
+StartTrappers=5
+
+# Listen interface for trapper. Trapper will listen all network interfaces
+# if this parameter is missing.
+ListenIP=127.0.0.1
+
+# Listen port for trapping. Default port number is 10051. This parameter
+# must be between 1024 and 32767
+ListenPort=10051
+
+# How often ZABBIX will perform housekeeping procedure
+# (in hours)
+# Default value is 1 hour
+# Housekeeping is removing unnecessary information from
+# tables history, alert, and alarms
+# This parameter must be between 1 and 24
+HousekeepingFrequency=1
+
+# How often ZABBIX will try to send unsent alerts
+# (in seconds)
+# Default value is 30 seconds
+SenderFrequency=30
+
+# Uncomment this line to disable housekeeping procedure
+#DisableHousekeeping=1
+
+# Specifies debug level
+# 0 - debug is not created
+# 1 - critical information
+# 2 - error information
+# 3 - warnings (default)
+# 4 - for debugging (produces lots of information)
+DebugLevel=3
+
+# Specifies how long we wait for agent (in sec)
+# Must be between 1 and 30
+Timeout=5
+
+# After how many seconds of unreachability treat a host as unavailable
+UnreachablePeriod=45
+
+# How ofter check host for availability during the unreachability period
+UnavailableDelay=15
+
+# How ofter check host for availability during the unavailability period
+UnavailableDelay=60
+
+# Name of PID file
+PidFile=/var/run/zabbix/zabbix_server.pid
+
+# Name of log file
+# If not set, syslog is used
+LogFile=/var/log/zabbix/zabbix_server.log
+
+#Location for custom alert scripts
+AlertScriptsPath=/var/lib/zabbix/scripts
+
+#Location of 'fping. Default is /usr/sbin/fping
+FpingLocation=/usr/sbin/fping
+
+# Frequency of ICMP pings. Defauls is 30 second.
+PingerFrequency=30
+
+# Database host name
+# Default is localhost
+DBHost=localhost
+
+# Database name
+DBName=zabbix
+
+# Database user
+DBUser=zabbix
+
+# Database password
+# Comment this line if no password used
+DBPassword=zabbix
+
+# Connect to MySQL using Unix socket?
+#DBSocket=/var/run/mysqld/mysqld.sock
diff --git a/net-analyzer/zabbix/files/digest-zabbix-1.4.1 b/net-analyzer/zabbix/files/digest-zabbix-1.4.1
new file mode 100644
index 000000000000..27148db98b93
--- /dev/null
+++ b/net-analyzer/zabbix/files/digest-zabbix-1.4.1
@@ -0,0 +1,3 @@
+MD5 c9e9a12eeb3ae784075cb7899f200889 zabbix-1.4.1.tar.gz 3246817
+RMD160 6afcf78adf0e5f192c0cd36a01ca7802a3c8e94b zabbix-1.4.1.tar.gz 3246817
+SHA256 631445f5a1a9b0852bb20644cfdf735d8e1ecdc04c4c0a9b394bfb3429a5a6dc zabbix-1.4.1.tar.gz 3246817
diff --git a/net-analyzer/zabbix/zabbix-1.4.1.ebuild b/net-analyzer/zabbix/zabbix-1.4.1.ebuild
new file mode 100644
index 000000000000..f301293854c1
--- /dev/null
+++ b/net-analyzer/zabbix/zabbix-1.4.1.ebuild
@@ -0,0 +1,264 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix/zabbix-1.4.1.ebuild,v 1.1 2007/07/24 11:49:19 wschlich Exp $
+
+inherit eutils flag-o-matic webapp depend.php
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="agent curl frontend jabber ldap mysql oracle postgres server snmp sqlite3"
+DEPEND="virtual/libc
+ snmp? ( net-analyzer/net-snmp )
+ ldap? (
+ net-nds/openldap
+ =dev-libs/cyrus-sasl-2*
+ net-libs/gnutls
+ )
+ mysql? ( virtual/mysql )
+ sqlite3? ( =dev-db/sqlite-3* )
+ postgres? ( dev-db/libpq )
+ jabber? ( dev-libs/iksemel )
+ curl? ( net-misc/curl )"
+RDEPEND="${RDEPEND}
+ server? ( net-analyzer/fping )"
+
+useq frontend && need_php_httpd
+
+pkg_setup() {
+ if useq server; then
+ local dbnum dbtypes="mysql oracle postgres sqlite3" dbtype
+ declare -i dbnum=0
+ for dbtype in ${dbtypes}; do
+ useq ${dbtype} && let dbnum++
+ done
+ if [ ${dbnum} -gt 1 ]; then
+ eerror
+ eerror "You can't use more than one database type in Zabbix."
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "Multiple database types selected."
+ elif [ ${dbnum} -lt 1 ]; then
+ eerror
+ eerror "Select exactly one database type out of these: ${dbtypes}"
+ eerror
+ die "No database type selected."
+ fi
+ if useq oracle; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror "The environment variable ORACLE_HOME must be set"
+ eerror "and point to the correct location."
+ eerror "It looks like you don't have Oracle installed."
+ eerror
+ die "Environment variable ORACLE_HOME is not set"
+ fi
+ if has_version 'dev-db/oracle-instantclient-basic'; then
+ ewarn
+ ewarn "Please ensure you have a full install of the Oracle client."
+ ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+ ewarn
+ fi
+ fi
+ fi
+
+ if useq frontend; then
+ webapp_pkg_setup
+ require_gd
+ fi
+
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+pkg_postinst() {
+ if useq server; then
+ elog
+ elog "You need to configure your database for Zabbix."
+ elog
+ elog "Have a look at /usr/share/zabbix/database for"
+ elog "database creation and upgrades."
+ elog
+ elog "For more info read the Zabbix manual at"
+ elog "http://www.zabbix.com/manual/v1.4/"
+ elog
+
+ zabbix_homedir="$(egetent passwd zabbix | cut -d : -f 6 )"
+ if [ -n "${zabbix_homedir}" ] && \
+ [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+ ewarn
+ ewarn "The user 'zabbix' should have his homedir changed"
+ ewarn "to /var/lib/zabbix/home if you want to use"
+ ewarn "custom alert scripts."
+ ewarn
+ ewarn "A real homedir might be needed for configfiles"
+ ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+ ewarn "using sendxmpp for Jabber alerts)."
+ ewarn
+ ewarn "To change the homedir use:"
+ ewarn " usermod -d /var/lib/zabbix/home zabbix"
+ ewarn
+ fi
+ fi
+
+ # repeat fowners/fperms functionality from src_install()
+ # here to catch wrong permissions on existing files in
+ # the live filesystem (yeah, that sucks).
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix \
+ ${ROOT}var/lib/zabbix \
+ ${ROOT}var/lib/zabbix/home \
+ ${ROOT}var/lib/zabbix/scripts \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ chmod 0750 \
+ ${ROOT}etc/zabbix \
+ ${ROOT}var/lib/zabbix \
+ ${ROOT}var/lib/zabbix/home \
+ ${ROOT}var/lib/zabbix/scripts \
+ ${ROOT}var/log/zabbix \
+ ${ROOT}var/run/zabbix
+ if useq server; then
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix/zabbix_server.conf
+ chmod 0640 \
+ ${ROOT}etc/zabbix/zabbix_server.conf
+ fi
+ if useq agent; then
+ chown zabbix:zabbix \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf
+ chmod 0640 \
+ ${ROOT}etc/zabbix/zabbix_agent.conf \
+ ${ROOT}etc/zabbix/zabbix_agentd.conf
+ fi
+
+ if useq server; then
+ # check for fping
+ fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+ case "${fping_perms}" in
+ 4[157][157][157])
+ ;;
+ *)
+ ewarn
+ ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+ ewarn "you have to make /usr/sbin/fping setuid root and executable"
+ ewarn "by everyone. Run the following command to fix it:"
+ ewarn
+ ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+ ewarn
+ ewarn "Please be aware that this might impose a security risk,"
+ ewarn "depending on the code quality of fping."
+ ewarn
+ ebeep 3
+ epause 5
+ ;;
+ esac
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable server) \
+ $(use_enable agent) \
+ $(use_with ldap) \
+ $(use_with snmp net-snmp) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with oracle) \
+ $(use_with sqlite3) \
+ $(use_with jabber) \
+ $(use_with curl libcurl) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ keepdir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ if useq server; then
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_server.conf
+ doinitd \
+ ${FILESDIR}/${PV}/init.d/zabbix-server
+ dosbin \
+ src/zabbix_server/zabbix_server
+ dodir \
+ /usr/share/zabbix/database
+ insinto /usr/share/zabbix/database
+ doins -r \
+ upgrades \
+ create
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_server.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_server.conf
+ fi
+
+ if useq agent; then
+ insinto /etc/zabbix
+ doins \
+ ${FILESDIR}/${PV}/zabbix_agent.conf \
+ ${FILESDIR}/${PV}/zabbix_agentd.conf
+ doinitd \
+ ${FILESDIR}/${PV}/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_get/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fi
+
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/log/zabbix \
+ /var/run/zabbix
+
+ dodoc README INSTALL NEWS ChangeLog
+
+ if useq frontend; then
+ webapp_src_preinst
+ cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+ webapp_postinst_txt en ${FILESDIR}/${PV}/postinstall-en.txt
+ webapp_configfile \
+ ${MY_HTDOCSDIR}/include/db.inc.php \
+ ${MY_HTDOCSDIR}/include/config.inc.php
+ webapp_src_install
+ fi
+}