summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-01-08 18:50:33 +0000
committerPeter Volkov <pva@gentoo.org>2008-01-08 18:50:33 +0000
commit4903e056816971d65a8678d536f760206b9443ad (patch)
tree045488b841d9a28b49f3df8ff7bb96d6293bc126 /net-analyzer/vnstat
parentMarked ~hppa (bug #204038). (diff)
downloadgentoo-2-4903e056816971d65a8678d536f760206b9443ad.tar.gz
gentoo-2-4903e056816971d65a8678d536f760206b9443ad.tar.bz2
gentoo-2-4903e056816971d65a8678d536f760206b9443ad.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-analyzer/vnstat')
-rw-r--r--net-analyzer/vnstat/ChangeLog9
-rw-r--r--net-analyzer/vnstat/files/digest-vnstat-1.63
-rw-r--r--net-analyzer/vnstat/vnstat-1.6.ebuild70
3 files changed, 80 insertions, 2 deletions
diff --git a/net-analyzer/vnstat/ChangeLog b/net-analyzer/vnstat/ChangeLog
index d3d53302ec1e..c00ea613df9a 100644
--- a/net-analyzer/vnstat/ChangeLog
+++ b/net-analyzer/vnstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/vnstat
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/ChangeLog,v 1.26 2007/12/26 17:28:51 pva Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/ChangeLog,v 1.27 2008/01/08 18:50:33 pva Exp $
+
+*vnstat-1.6 (08 Jan 2008)
+
+ 08 Jan 2008; <pva@gentoo.org> +vnstat-1.6.ebuild:
+ Version bump.
*vnstat-1.5 (26 Dec 2007)
diff --git a/net-analyzer/vnstat/files/digest-vnstat-1.6 b/net-analyzer/vnstat/files/digest-vnstat-1.6
new file mode 100644
index 000000000000..69474a56b83a
--- /dev/null
+++ b/net-analyzer/vnstat/files/digest-vnstat-1.6
@@ -0,0 +1,3 @@
+MD5 ccaffe8e70d47e0cf2f25e52daa25712 vnstat-1.6.tar.gz 36888
+RMD160 4aa0b4664a29a4201adbf7bb2184ff4858a60d46 vnstat-1.6.tar.gz 36888
+SHA256 80bac32b80c4b7bdead7a5a54229728a6bc11a9285493cd39946fe94b303d3c8 vnstat-1.6.tar.gz 36888
diff --git a/net-analyzer/vnstat/vnstat-1.6.ebuild b/net-analyzer/vnstat/vnstat-1.6.ebuild
new file mode 100644
index 000000000000..fa9628926552
--- /dev/null
+++ b/net-analyzer/vnstat/vnstat-1.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/vnstat-1.6.ebuild,v 1.1 2008/01/08 18:50:33 pva Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
+HOMEPAGE="http://humdi.net/vnstat/"
+SRC_URI="http://humdi.net/vnstat/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/cron"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install() {
+ dobin src/vnstat || die
+ exeinto /etc/cron.hourly
+ newexe "${FILESDIR}"/vnstat.cron vnstat
+
+ insinto /etc
+ doins cfg/vnstat.conf
+
+ doman man/vnstat.1
+
+ keepdir /var/lib/vnstat
+
+ newdoc pppd/vnstat_ip-up ip-up.example
+ newdoc pppd/vnstat_ip-down ip-down.example
+ dodoc CHANGES README UPGRADE FAQ
+ newdoc INSTALL README.setup
+}
+
+pkg_postinst() {
+ # compatibility for 1.1 ebuild
+ if [[ -d ${ROOT}/var/spool/vnstat ]] ; then
+ mv -f "${ROOT}"/var/spool/vnstat/* "${ROOT}"/var/lib/vnstat/ \
+ && rmdir "${ROOT}"/var/spool/vnstat
+ elog "vnStat db files moved from /var/spool/vnstat to /var/lib/vnstat"
+ elog
+ fi
+
+ elog "Repeat the following command for every interface you"
+ elog "wish to monitor (replace eth0):"
+ elog " vnstat -u -i eth0"
+ elog
+ elog "Note: if an interface transfers more than ~4GB in"
+ elog "the time between cron runs, you may miss traffic"
+ elog
+
+ if [[ -e ${ROOT}/etc/cron.d/vnstat ]] ; then
+ elog "vnstat's cron script is now installed as /etc/cron.hourly/vnstat."
+ elog "Please remove /etc/cron.d/vnstat."
+ elog
+ else
+ elog "A cron script has been installed to /etc/cron.hourly/vnstat."
+ elog
+ fi
+ elog "To update your interface database automatically with"
+ elog "cron, uncomment the lines in /etc/cron.hourly/vnstat."
+ elog
+ elog "Starting with version 1.5 --dbdir option is droped. You can do the same"
+ elog "with DatabaseDir directive in configuration file (/etc/vnstat.conf)."
+}