summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-13 17:21:44 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-13 17:21:44 +0000
commitd88043994b770ec0f7ecbb6b6f0b445bdf6de8af (patch)
treefcd13fb8cbc1ea1ff2cce4dbb9d9b62ddf730c62 /net-analyzer/tcpslice
parentAdded !virtual/mailx to DEPEND, since we provide it. (Manifest recommit) (diff)
downloadgentoo-2-d88043994b770ec0f7ecbb6b6f0b445bdf6de8af.tar.gz
gentoo-2-d88043994b770ec0f7ecbb6b6f0b445bdf6de8af.tar.bz2
gentoo-2-d88043994b770ec0f7ecbb6b6f0b445bdf6de8af.zip
fix #63888 to compile with pcap correctly
Diffstat (limited to 'net-analyzer/tcpslice')
-rw-r--r--net-analyzer/tcpslice/ChangeLog5
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/net-analyzer/tcpslice/ChangeLog b/net-analyzer/tcpslice/ChangeLog
index 3f5b0e4f8c6c..dfe44313a806 100644
--- a/net-analyzer/tcpslice/ChangeLog
+++ b/net-analyzer/tcpslice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/tcpslice
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.6 2004/07/10 11:19:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/ChangeLog,v 1.7 2004/09/13 17:21:44 squinky86 Exp $
+
+ 13 Sep 2004; Jon Hood <squinky86@gentoo.org> tcpslice-1.1_alpha3.ebuild:
+ Compile correctly with pcap, bug #63888.
10 Jul 2004; Eldad Zack <eldad@gentoo.org> tcpslice-1.1_alpha3.ebuild:
Changed to mirror://debian
diff --git a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
index 4119a2287c78..440e9e311383 100644
--- a/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
+++ b/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.7 2004/07/10 11:19:37 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpslice/tcpslice-1.1_alpha3.ebuild,v 1.8 2004/09/13 17:21:44 squinky86 Exp $
inherit eutils
@@ -18,14 +18,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/libc
+
+RDEPEND="virtual/libc
>=net-libs/libpcap-0.6.2-r1"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
S=${WORKDIR}/tcpslice-1.1a3
src_unpack() {
unpack ${A}
epatch ${DISTDIR}/tcpslice_1.1a3-1.1.diff.gz
+ cd ${S}
+ sed -i -e 's:net/bpf.h:pcap-bpf.h:g' tcpslice.c || die
}
src_compile() {