summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-01-15 06:37:32 +0000
committerJeroen Roovers <jer@gentoo.org>2009-01-15 06:37:32 +0000
commit84b47803a0418b4e06a307b000713063ec41f00d (patch)
tree02949b8e2c1fcfa496ee08c7e0bb2889744171b0 /net-analyzer/sniffit
parentFix config file permissions too. (diff)
downloadgentoo-2-84b47803a0418b4e06a307b000713063ec41f00d.tar.gz
gentoo-2-84b47803a0418b4e06a307b000713063ec41f00d.tar.bz2
gentoo-2-84b47803a0418b4e06a307b000713063ec41f00d.zip
Do not hide compiler warnings. Do not hardcode CFLAGS in Makefile. Do not strip (bug #251985).
(Portage version: 2.2_rc22/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'net-analyzer/sniffit')
-rw-r--r--net-analyzer/sniffit/ChangeLog9
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch22
-rw-r--r--net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild14
3 files changed, 36 insertions, 9 deletions
diff --git a/net-analyzer/sniffit/ChangeLog b/net-analyzer/sniffit/ChangeLog
index 6f200546ea29..80c5836857fd 100644
--- a/net-analyzer/sniffit/ChangeLog
+++ b/net-analyzer/sniffit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/sniffit
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/ChangeLog,v 1.14 2007/09/06 18:11:08 jokey Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/ChangeLog,v 1.15 2009/01/15 06:37:32 jer Exp $
+
+ 15 Jan 2009; Jeroen Roovers <jer@gentoo.org>
+ +files/sniffit-0.3.7-gentoo.patch, sniffit-0.3.7-r1.ebuild:
+ Do not hide compiler warnings. Do not hardcode CFLAGS in Makefile. Do not
+ strip (bug #251985).
06 Sep 2007; Markus Ullmann <jokey@gentoo.org> -sniffit-0.3.7.ebuild:
Cleanup
diff --git a/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch b/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch
new file mode 100644
index 000000000000..680eb07a6833
--- /dev/null
+++ b/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch
@@ -0,0 +1,22 @@
+--- sniffit.0.3.7.beta/Makefile.in.orig 2009-01-15 07:28:39.000000000 +0100
++++ sniffit.0.3.7.beta/Makefile.in 2009-01-15 07:28:26.000000000 +0100
+@@ -10,9 +10,9 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@
+ OS_OPT = @OS_OPT@
+-OBJ_FLAG = -w -O2 -c
++OBJ_FLAG = $(CFLAGS) -c
+ OBJ_OPT = -I./libpcap -L./libpcap
+-EXE_FLAG = -w -O2 -o sniffit
++EXE_FLAG = $(CFLAGS) -o sniffit
+ EXE_OPT = -I./libpcap -L./libpcap -lpcap
+ EXE_OBJ = sn_packets.o sn_generation.o sn_interface.o sn_cfgfile.o \
+ sn_logfile.o sn_resolv.o
+@@ -28,7 +28,6 @@
+ sniffit: $(SNIFFIT) $(DEP_FILES)
+ # cd libpcap; make; cd ..
+ $(CC) $(EXE_FLAG) $(SNIFFIT) $(EXE_OBJ) $(EXE_OPT) $(LIBS) $(DEFS) $(OS_OPT)
+- strip sniffit
+
+ sn_cfgfile.o: sn_cfgfile.h sn_cfgfile.c sn_defines.h sn_structs.h sn_config.h
+ $(CC) $(OBJ_FLAG) sn_cfgfile.c $(OBJ_OPT) $(DEFS)
diff --git a/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild b/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild
index 43f43f5d2460..a85e058406c3 100644
--- a/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild
+++ b/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild,v 1.9 2007/07/11 23:49:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sniffit/sniffit-0.3.7-r1.ebuild,v 1.10 2009/01/15 06:37:32 jer Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P="${P/-/.}.beta"
S="${WORKDIR}/${MY_P}"
@@ -27,18 +27,18 @@ src_unpack() {
# Fix issues with gcc-3.3 (bug #25328)
epatch ${FILESDIR}/${P}-gcc33.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
}
src_compile() {
+ tc-export CC
econf || die
-
- emake OBJ_FLAG="-w -c ${CFLAGS}" \
- EXE_FLAG="-w ${CFLAGS} -o sniffit" || die
+ emake CFLAGS="${CFLAGS}" || die
}
src_install () {
dobin sniffit
doman sniffit.5 sniffit.8
- dodoc README* PLUGIN-HOWTO BETA* HISTORY LICENSE changelog
+ dodoc README* PLUGIN-HOWTO BETA* HISTORY LICENSE
}