summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-28 09:03:43 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-28 09:03:43 +0000
commitf12a0f67ced8d9ad763d300cad246d2a3f493ef9 (patch)
tree53d6f5adf51db94c3f44dacc3aa858135777c03f /net-analyzer/sarg
parentsci-chemistry/pdb2pqr: Allow multi py ABI installations, clean installation (diff)
downloadgentoo-2-f12a0f67ced8d9ad763d300cad246d2a3f493ef9.tar.gz
gentoo-2-f12a0f67ced8d9ad763d300cad246d2a3f493ef9.tar.bz2
gentoo-2-f12a0f67ced8d9ad763d300cad246d2a3f493ef9.zip
Fix bashisms in configure script (bug #527136).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/ChangeLog6
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch102
-rw-r--r--net-analyzer/sarg/sarg-2.3.9.ebuild6
3 files changed, 111 insertions, 3 deletions
diff --git a/net-analyzer/sarg/ChangeLog b/net-analyzer/sarg/ChangeLog
index e377c1e55aaf..c27d8c84b113 100644
--- a/net-analyzer/sarg/ChangeLog
+++ b/net-analyzer/sarg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/sarg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.87 2014/09/26 08:42:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.88 2014/10/28 09:03:43 jer Exp $
+
+ 28 Oct 2014; Jeroen Roovers <jer@gentoo.org> sarg-2.3.9.ebuild,
+ +files/sarg-2.3.9-configure-bash.patch:
+ Fix bashisms in configure script (bug #527136).
*sarg-2.3.9 (26 Sep 2014)
diff --git a/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch b/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch
new file mode 100644
index 000000000000..ddc0ca8ec4eb
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.9-configure-bash.patch
@@ -0,0 +1,102 @@
+--- a/configure.in
++++ b/configure.in
+@@ -41,7 +41,7 @@
+ CFLAGS="${CFLAGS} -Wextra -Wno-unused-parameter"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_extra_warnings="yes"],[have_extra_warnings="no"])
+ AC_MSG_RESULT($have_extra_warnings)
+-if test "$have_extra_warnings" == "no" ; then
++if test "$have_extra_warnings" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -50,7 +50,7 @@
+ CFLAGS="${CFLAGS} -Werror=implicit-function-declaration"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_implicit_function_declaration="yes"],[have_implicit_function_declaration="no"])
+ AC_MSG_RESULT($have_implicit_function_declaration)
+-if test "$have_implicit_function_declaration" == "no" ; then
++if test "$have_implicit_function_declaration" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -59,7 +59,7 @@
+ CFLAGS="${CFLAGS} -Werror=format"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_error_format="yes"],[have_error_format="no"])
+ AC_MSG_RESULT($have_error_format)
+-if test "$have_error_format" == "no" ; then
++if test "$have_error_format" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -93,7 +93,7 @@
+ [],[with_gd=check])
+ if ( test "x$with_gd" != "xno" ) ; then
+ AC_CHECK_HEADERS(gd.h gdfontl.h gdfontt.h gdfonts.h gdfontmb.h gdfontg.h)
+- if ( test "x$ac_cv_header_gd_h" == "xyes" ) ; then
++ if ( test "x$ac_cv_header_gd_h" = "xyes" ) ; then
+ AC_CHECK_LIB(gd, gdImagePng,LIBS="-lgd ${LIBS}"; HAVE_GD_LIB="yes", HAVE_GD_LIB="")
+ if ( test "x$HAVE_GD_LIB" != "xyes" ) ; then
+ AC_MSG_ERROR([ligbd is required to compile sarg with gd])
+@@ -137,7 +137,7 @@
+ [],[with_pcre=check])
+ if ( test "x$with_pcre" != "xno" ) ; then
+ AC_CHECK_HEADERS(pcre.h)
+- if ( test "x$ac_cv_header_pcre_h" == "xyes" ) ; then
++ if ( test "x$ac_cv_header_pcre_h" = "xyes" ) ; then
+ LIBS="$LIBS $(pcre-config --libs)"
+ CFLAGS="$CFLAGS $(pcre-config --cflags)"
+ else
+@@ -243,7 +243,7 @@
+ fi
+ ],[FONTDIR="${datarootdir}/sarg/fonts"])
+ if test "$FONTDIR" ; then
+- if test "x$prefix" == "xNONE" ; then
++ if test "x$prefix" = "xNONE" ; then
+ tempfullpath=`prefix=$ac_default_prefix ; eval "echo $FONTDIR"`
+ else
+ tempfullpath=`eval "echo $FONTDIR"`
+@@ -261,7 +261,7 @@
+ IMAGEDIR=$enableval
+ fi
+ ],[IMAGEDIR="${datarootdir}/sarg/images"])
+-if test "x$prefix" == "xNONE" ; then
++if test "x$prefix" = "xNONE" ; then
+ tempfullpath=`prefix=$ac_default_prefix ; eval "echo $IMAGEDIR"`
+ else
+ tempfullpath=`eval "echo $IMAGEDIR"`
+@@ -286,7 +286,7 @@
+ CFLAGS="${CFLAGS} -Wformat -Werror=format-security"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_format_security="yes"],[have_format_security="no"])
+ AC_MSG_RESULT($have_format_security)
+- if test "$have_format_security" == "no" ; then
++ if test "$have_format_security" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+@@ -295,7 +295,7 @@
+ CFLAGS="${CFLAGS} -Wempty-body"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_empty_body="yes"],[have_empty_body="no"])
+ AC_MSG_RESULT($have_empty_body)
+- if test "$have_empty_body" == "no" ; then
++ if test "$have_empty_body" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+ fi
+@@ -367,14 +367,14 @@
+ AC_CONFIG_FILES([Makefile po/Makefile.in])
+ AC_OUTPUT
+
+-if ( test "x$gd_status" == "xdisabled" ) ; then
++if ( test "x$gd_status" = "xdisabled" ) ; then
+ AC_MSG_NOTICE([Not building with gd as requested on the configuration command line])
+-elif ( test "x$gd_status" == "xnot found" ) ; then
++elif ( test "x$gd_status" = "xnot found" ) ; then
+ AC_MSG_NOTICE([gd.h was not found so the graphs won't be available in the report])
+ fi
+
+-if ( test "x$pcre_status" == "xdisabled" ) ; then
++if ( test "x$pcre_status" = "xdisabled" ) ; then
+ AC_MSG_NOTICE([Not building with pcre as requested on the configuration command line])
+-elif ( test "x$pcre_status" == "xnot found" ) ; then
++elif ( test "x$pcre_status" = "xnot found" ) ; then
+ AC_MSG_NOTICE([pcre.h was not found so the regexp won't be available in the hostalias])
+ fi
diff --git a/net-analyzer/sarg/sarg-2.3.9.ebuild b/net-analyzer/sarg/sarg-2.3.9.ebuild
index 241899fe7c0c..996061d765a8 100644
--- a/net-analyzer/sarg/sarg-2.3.9.ebuild
+++ b/net-analyzer/sarg/sarg-2.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.3.9.ebuild,v 1.1 2014/09/26 08:42:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.3.9.ebuild,v 1.2 2014/10/28 09:03:43 jer Exp $
EAPI=5
inherit autotools eutils
@@ -24,7 +24,9 @@ RDEPEND="${DEPEND}"
DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
src_prepare() {
- epatch "${FILESDIR}"/${P}-configure.patch
+ epatch \
+ "${FILESDIR}"/${P}-configure.patch \
+ "${FILESDIR}"/${P}-configure-bash.patch
sed -i \
-e 's:/usr/local/squid/var/logs/access.log:/var/log/squid/access.log:' \