summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-28 21:15:43 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-28 21:15:43 +0000
commit5450233863ef75178fab298562fe637f163c8233 (patch)
treec3615f2311191ab4e7a030a7930c6aafad8e226b /net-analyzer/pinger
parentFix a typo. (diff)
downloadgentoo-2-5450233863ef75178fab298562fe637f163c8233.tar.gz
gentoo-2-5450233863ef75178fab298562fe637f163c8233.tar.bz2
gentoo-2-5450233863ef75178fab298562fe637f163c8233.zip
Update to EAPI=2 and use slot deps for gtk+.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/pinger')
-rw-r--r--net-analyzer/pinger/ChangeLog8
-rw-r--r--net-analyzer/pinger/pinger-0.32.ebuild10
-rw-r--r--net-analyzer/pinger/pinger-0.32c.ebuild19
3 files changed, 20 insertions, 17 deletions
diff --git a/net-analyzer/pinger/ChangeLog b/net-analyzer/pinger/ChangeLog
index 0fc0c3826034..79dbce433034 100644
--- a/net-analyzer/pinger/ChangeLog
+++ b/net-analyzer/pinger/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/pinger
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/ChangeLog,v 1.11 2008/04/22 13:33:05 drac Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/ChangeLog,v 1.12 2011/03/28 21:15:43 radhermit Exp $
+
+ 28 Mar 2011; Tim Harder <radhermit@gentoo.org> pinger-0.32.ebuild,
+ pinger-0.32c.ebuild:
+ Update to EAPI=2 and use slot deps for gtk+.
22 Apr 2008; Samuli Suominen <drac@gentoo.org> pinger-0.32.ebuild,
pinger-0.32c.ebuild:
diff --git a/net-analyzer/pinger/pinger-0.32.ebuild b/net-analyzer/pinger/pinger-0.32.ebuild
index 36fc817a32b1..e8dbeaa2d573 100644
--- a/net-analyzer/pinger/pinger-0.32.ebuild
+++ b/net-analyzer/pinger/pinger-0.32.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32.ebuild,v 1.4 2008/04/22 13:33:05 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32.ebuild,v 1.5 2011/03/28 21:15:43 radhermit Exp $
+
+EAPI=2
DESCRIPTION="Cyclic multi ping utility for selected adresses using GTK/ncurses."
HOMEPAGE="http://aa.vslib.cz/silk/projekty/pinger/index.php"
@@ -11,12 +13,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.4
+RDEPEND=">=x11-libs/gtk+-2.4:2
sys-libs/ncurses"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_install() {
- make install DESTDIR="${D}"
+ emake install DESTDIR="${D}" || die "emake install failed"
dodoc AUTHORS BUGS ChangeLog NEWS README
}
diff --git a/net-analyzer/pinger/pinger-0.32c.ebuild b/net-analyzer/pinger/pinger-0.32c.ebuild
index 99f5fd05f0d5..f74e19253c93 100644
--- a/net-analyzer/pinger/pinger-0.32c.ebuild
+++ b/net-analyzer/pinger/pinger-0.32c.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32c.ebuild,v 1.4 2008/04/22 13:33:05 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pinger/pinger-0.32c.ebuild,v 1.5 2011/03/28 21:15:43 radhermit Exp $
+
+EAPI=2
inherit eutils autotools
@@ -14,29 +16,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gtk nls"
-RDEPEND="gtk? ( >=x11-libs/gtk+-2.4 )
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.4:2 )
sys-libs/ncurses"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/disable_gtk.patch
cp "${WORKDIR}"/gtk-2.0-for-pinger.m4 m4/
AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
! use nls && myconf="${myconf} --disable-nls"
econf \
$(use_enable gtk) \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
+ ${myconf}
}
src_install() {