summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-08-28 20:01:18 +0000
committerMichael Januszewski <spock@gentoo.org>2010-08-28 20:01:18 +0000
commit9dbea3525c7138dbca96603bde4367c95200b7e7 (patch)
treedfa40af8adbdb52d6bfd9dc8fa769cda60318a32 /net-analyzer/nmap
parentRestrict tests per bug #335027 (diff)
downloadgentoo-2-9dbea3525c7138dbca96603bde4367c95200b7e7.tar.gz
gentoo-2-9dbea3525c7138dbca96603bde4367c95200b7e7.tar.bz2
gentoo-2-9dbea3525c7138dbca96603bde4367c95200b7e7.zip
Version bump (bug #334559).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog7
-rw-r--r--net-analyzer/nmap/nmap-5.35.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 672fca28f0ea..138be47230b3 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.235 2010/08/13 03:56:16 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.236 2010/08/28 20:01:18 spock Exp $
+
+*nmap-5.35 (28 Aug 2010)
+
+ 28 Aug 2010; Michał Januszewski <spock@gentoo.org> +nmap-5.35.ebuild:
+ Version bump (bug #334559).
13 Aug 2010; Jeremy Olexa <darkside@gentoo.org> nmap-5.21-r1.ebuild:
arm stable, bug 330439
diff --git a/net-analyzer/nmap/nmap-5.35.ebuild b/net-analyzer/nmap/nmap-5.35.ebuild
new file mode 100644
index 000000000000..2909d3e0e445
--- /dev/null
+++ b/net-analyzer/nmap/nmap-5.35.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.35.ebuild,v 1.1 2010/08/28 20:01:18 spock Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit eutils flag-o-matic python
+
+MY_P=${P/_beta/BETA}
+MY_P="${MY_P}DC1"
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="http://nmap.org/dist/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="gtk lua ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5[sqlite]
+ >=dev-python/pysqlite-2 )
+ )
+ lua? ( >=dev-lang/lua-5.1.4-r1[deprecated] )
+ ssl? ( dev-libs/openssl )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.75-include.patch
+ epatch "${FILESDIR}"/${PN}-4.75-nolua.patch
+ epatch "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+ epatch "${FILESDIR}"/${PN}-5.21-python.patch
+ epatch "${FILESDIR}"/${PN}-5.21-openssl-1.patch
+ sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with lua liblua) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir="${EPREFIX}"/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}