summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-02-20 12:38:24 +0000
committerMichael Januszewski <spock@gentoo.org>2005-02-20 12:38:24 +0000
commite0f5ef312f4211c4c64b32f096d453a4a838dec3 (patch)
tree90273602f1653f3fc409dfc88ac0f54d2825e122 /net-analyzer/nmap/nmap-3.81.ebuild
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-e0f5ef312f4211c4c64b32f096d453a4a838dec3.tar.gz
gentoo-2-e0f5ef312f4211c4c64b32f096d453a4a838dec3.tar.bz2
gentoo-2-e0f5ef312f4211c4c64b32f096d453a4a838dec3.zip
Cleaned the ebuild up a little.
(Portage version: 2.0.51.16)
Diffstat (limited to 'net-analyzer/nmap/nmap-3.81.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.81.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-analyzer/nmap/nmap-3.81.ebuild b/net-analyzer/nmap/nmap-3.81.ebuild
index a2c27a848e87..9a946e76513e 100644
--- a/net-analyzer/nmap/nmap-3.81.ebuild
+++ b/net-analyzer/nmap/nmap-3.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.1 2005/02/08 17:08:02 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.2 2005/02/20 12:38:24 spock Exp $
inherit eutils
@@ -11,22 +11,22 @@ SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64 ~s390 ~ia64 ~ppc-macos"
-IUSE="gtk gnome ipv6"
+IUSE="gtk ssl"
DEPEND="virtual/libc
dev-libs/libpcre
- gtk? ( =x11-libs/gtk+-1.2* )"
+ gtk? ( =x11-libs/gtk+-1.2* )
+ ssl? ( dev-libs/openssl )"
src_compile() {
- econf `use_with gtk nmapfe` \
- `use_enable ipv6` || die
+ econf \
+ $(use_with gtk nmapfe) \
+ $(use_with ssl openssl) || die
emake -j1 || die
}
src_install() {
einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
- use gnome || rm -rf ${D}/usr/share/gnome/
-
dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
dohtml docs/*.html
}