summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-27 03:25:08 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-27 03:25:08 +0000
commit792236a64971b44f7af02f6b2028bb14571305b3 (patch)
tree78ddc92c2cd3729c01fa997214efc9ab3ecf8f38 /net-analyzer/nfdump
parentVersion bump. Replace shipped minilzo (bug #515278). Work around parallel mak... (diff)
downloadgentoo-2-792236a64971b44f7af02f6b2028bb14571305b3.tar.gz
gentoo-2-792236a64971b44f7af02f6b2028bb14571305b3.tar.bz2
gentoo-2-792236a64971b44f7af02f6b2028bb14571305b3.zip
Replace src_test() workaround with a proper test dependency.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/nfdump')
-rw-r--r--net-analyzer/nfdump/ChangeLog6
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.12-test-dep.patch11
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.12.ebuild8
3 files changed, 19 insertions, 6 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index b338d06e663a..123eddfa46e1 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nfdump
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.36 2014/06/27 03:14:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.37 2014/06/27 03:25:08 jer Exp $
+
+ 27 Jun 2014; Jeroen Roovers <jer@gentoo.org> nfdump-1.6.12.ebuild,
+ +files/nfdump-1.6.12-test-dep.patch:
+ Replace src_test() workaround with a proper test dependency.
*nfdump-1.6.12 (27 Jun 2014)
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.12-test-dep.patch b/net-analyzer/nfdump/files/nfdump-1.6.12-test-dep.patch
new file mode 100644
index 000000000000..312809afe7a7
--- /dev/null
+++ b/net-analyzer/nfdump/files/nfdump-1.6.12-test-dep.patch
@@ -0,0 +1,11 @@
+--- a/bin/Makefile.am
++++ b/bin/Makefile.am
+@@ -5,6 +5,8 @@
+ check_PROGRAMMS = test.sh
+ TESTS = nftest test.sh
+
++test.sh: nfgen
++
+ if SFLOW
+ bin_PROGRAMS += sfcapd
+ endif
diff --git a/net-analyzer/nfdump/nfdump-1.6.12.ebuild b/net-analyzer/nfdump/nfdump-1.6.12.ebuild
index 1e0f74099d7f..0928ed02d1ce 100644
--- a/net-analyzer/nfdump/nfdump-1.6.12.ebuild
+++ b/net-analyzer/nfdump/nfdump-1.6.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.12.ebuild,v 1.1 2014/06/27 03:14:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.12.ebuild,v 1.2 2014/06/27 03:25:08 jer Exp $
EAPI=5
inherit autotools eutils
@@ -39,6 +39,8 @@ DOCS=( AUTHORS ChangeLog NEWS README )
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-test-dep.patch
+
# bug #515278
cp "${WORKDIR}"/minilzo-2.07/*.{c,h} "${S}"/bin || die
@@ -64,7 +66,3 @@ src_configure() {
$(use_enable readpcap) \
$(use_enable sflow)
}
-
-src_test() {
- emake -j1 check
-}