summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-02-01 19:17:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-02-01 19:17:45 +0000
commitdfea3ac3e334de9372eca0b70d4fbf232d51ee25 (patch)
tree9d668f6dd325b2550afb3fa9cc6914f5480d33cb /net-analyzer/nettop
parentMask Amarok 1.4.5 for pre-release (and mtp). (diff)
downloadgentoo-2-dfea3ac3e334de9372eca0b70d4fbf232d51ee25.tar.gz
gentoo-2-dfea3ac3e334de9372eca0b70d4fbf232d51ee25.tar.bz2
gentoo-2-dfea3ac3e334de9372eca0b70d4fbf232d51ee25.zip
Fix a small off-by-one error per bug #139640 thanks to basic@mozdev.org for the patch
(Portage version: 2.1.2-r1)
Diffstat (limited to 'net-analyzer/nettop')
-rw-r--r--net-analyzer/nettop/ChangeLog12
-rw-r--r--net-analyzer/nettop/files/digest-nettop-0.2.3-r1 (renamed from net-analyzer/nettop/files/digest-nettop-0.2.3)0
-rw-r--r--net-analyzer/nettop/files/nettop-0.2.3-gcc411.patch (renamed from net-analyzer/nettop/files/nettop.c.patch)0
-rw-r--r--net-analyzer/nettop/files/nettop-0.2.3-offbyone.patch29
-rw-r--r--net-analyzer/nettop/nettop-0.2.3-r1.ebuild (renamed from net-analyzer/nettop/nettop-0.2.3.ebuild)13
5 files changed, 46 insertions, 8 deletions
diff --git a/net-analyzer/nettop/ChangeLog b/net-analyzer/nettop/ChangeLog
index c094a85f83fe..697a2bfed987 100644
--- a/net-analyzer/nettop/ChangeLog
+++ b/net-analyzer/nettop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/nettop
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.15 2006/07/28 06:12:25 dragonheart Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/ChangeLog,v 1.16 2007/02/01 19:17:45 jokey Exp $
+
+*nettop-0.2.3-r1 (01 Feb 2007)
+
+ 01 Feb 2007; Markus Ullmann <jokey@gentoo.org>
+ +files/nettop-0.2.3-gcc411.patch, +files/nettop-0.2.3-offbyone.patch,
+ -files/nettop.c.patch, -nettop-0.2.3.ebuild, +nettop-0.2.3-r1.ebuild:
+ Fix a small off-by-one error per bug #139640 thanks to basic@mozdev.org for
+ the patch
28 Jul 2006; Daniel Black <dragonheart@gentoo.org> nettop-0.2.3.ebuild:
slang dependency fix as per bug #141947 thanks Diego
diff --git a/net-analyzer/nettop/files/digest-nettop-0.2.3 b/net-analyzer/nettop/files/digest-nettop-0.2.3-r1
index 626cebcb1308..626cebcb1308 100644
--- a/net-analyzer/nettop/files/digest-nettop-0.2.3
+++ b/net-analyzer/nettop/files/digest-nettop-0.2.3-r1
diff --git a/net-analyzer/nettop/files/nettop.c.patch b/net-analyzer/nettop/files/nettop-0.2.3-gcc411.patch
index 227611c4ceb4..227611c4ceb4 100644
--- a/net-analyzer/nettop/files/nettop.c.patch
+++ b/net-analyzer/nettop/files/nettop-0.2.3-gcc411.patch
diff --git a/net-analyzer/nettop/files/nettop-0.2.3-offbyone.patch b/net-analyzer/nettop/files/nettop-0.2.3-offbyone.patch
new file mode 100644
index 000000000000..0903ebaa7e01
--- /dev/null
+++ b/net-analyzer/nettop/files/nettop-0.2.3-offbyone.patch
@@ -0,0 +1,29 @@
+--- nettop.c.old 2006-07-08 13:24:40.000000000 +0000
++++ nettop.c 2006-07-08 14:03:42.000000000 +0000
+@@ -384,7 +385,7 @@
+ void
+ screen_update()
+ {
+- struct node *sorted[24] = {0};
++ struct node *sorted[25] = {0};
+ unsigned long long sump, sums, valp, vals;
+ unsigned long long xfrrate = 0;
+ int i, do_ipprint, last[3] = {0};
+@@ -512,7 +513,7 @@
+ void
+ ipprint(int last[])
+ {
+- struct node *sorted[24] = {0};
++ struct node *sorted[25] = {0};
+ struct ent *proto;
+ unsigned long long valp, vals, sump, sums;
+ unsigned long long xfrrate = 0;
+@@ -575,7 +576,7 @@
+ void
+ servprint(int last[], struct node *tree, int type)
+ {
+- struct node *sorted[24] = {0};
++ struct node *sorted[25] = {0};
+ struct ent *e;
+ struct ent *service;
+ unsigned long long vals, valp, sums, sump;
diff --git a/net-analyzer/nettop/nettop-0.2.3.ebuild b/net-analyzer/nettop/nettop-0.2.3-r1.ebuild
index 904cda05aeaf..c3de675784ce 100644
--- a/net-analyzer/nettop/nettop-0.2.3.ebuild
+++ b/net-analyzer/nettop/nettop-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3.ebuild,v 1.15 2006/07/28 06:12:25 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nettop/nettop-0.2.3-r1.ebuild,v 1.1 2007/02/01 19:17:45 jokey Exp $
inherit eutils
@@ -20,17 +20,18 @@ DEPEND="=sys-libs/slang-1*
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/nettop.c.patch
+ epatch "${FILESDIR}"/${P}-gcc411.patch
+ epatch "${FILESDIR}"/${P}-offbyone.patch
}
src_compile() {
local myconf
myconf="--prefix=/usr"
- ./configure ${myconf} || die
- emake || die
+ ./configure ${myconf} || die "configure failed"
+ emake || die "emake failed"
}
src_install() {
- dosbin nettop || die
+ dosbin nettop
dodoc ChangeLog README THANKS
}