summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-05 10:08:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-05 10:08:09 +0000
commitccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784 (patch)
tree57921da938d2753668c896eca1bb303ebc2c3bf7 /net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild
parentx86 stable wrt #249491 (diff)
downloadgentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.tar.gz
gentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.tar.bz2
gentoo-2-ccb48e9b0fd983538d8d1aebdd1eaaf19a4fd784.zip
Version bump with GCC 4.3 and GLIBC 2.8 patch.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild b/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild
new file mode 100644
index 000000000000..a86056a0348c
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nethogs/nethogs-0.6.1_pre2.ebuild,v 1.1 2008/12/05 10:08:09 ssuominen Exp $
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://nethogs.sf.net/"
+SRC_URI="http://${PN}.sourceforge.net/${P/_/-}.tar.gz"
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -e "s:-O2:${CFLAGS}:g" -e "s:g++:$(tc-getCXX):g" \
+ -e "s:gcc:$(tc-getCC):g" -i Makefile || die "sed failed."
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc Changelog DESIGN README
+}