summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-19 21:02:56 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-19 21:02:56 +0000
commitdf51e4e7e277d8a46bcecdbc9126fc62841c285b (patch)
tree4f579ec045d9a777ec2d4c51a9daf24b9d6e6146 /net-analyzer/mtr
parentStable for arm, wrt bug #457664 (diff)
downloadgentoo-2-df51e4e7e277d8a46bcecdbc9126fc62841c285b.tar.gz
gentoo-2-df51e4e7e277d8a46bcecdbc9126fc62841c285b.tar.bz2
gentoo-2-df51e4e7e277d8a46bcecdbc9126fc62841c285b.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/mtr')
-rw-r--r--net-analyzer/mtr/ChangeLog9
-rw-r--r--net-analyzer/mtr/mtr-0.83.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/net-analyzer/mtr/ChangeLog b/net-analyzer/mtr/ChangeLog
index 8d777261fd54..f77b080b40dc 100644
--- a/net-analyzer/mtr/ChangeLog
+++ b/net-analyzer/mtr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/mtr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.127 2012/05/10 21:48:15 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/ChangeLog,v 1.128 2013/02/19 21:02:56 jer Exp $
+
+*mtr-0.83 (19 Feb 2013)
+
+ 19 Feb 2013; Jeroen Roovers <jer@gentoo.org> +mtr-0.83.ebuild:
+ Version bump.
10 May 2012; Tim Harder <radhermit@gentoo.org> -mtr-0.81.ebuild:
Remove old.
diff --git a/net-analyzer/mtr/mtr-0.83.ebuild b/net-analyzer/mtr/mtr-0.83.ebuild
new file mode 100644
index 000000000000..545db37897cf
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.83.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mtr/mtr-0.83.ebuild,v 1.1 2013/02/19 21:02:56 jer Exp $
+
+EAPI="4"
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz
+ mirror://gentoo/gtk-2.0-for-mtr.m4.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="gtk ipv6 suid"
+
+RDEPEND="
+ sys-libs/ncurses
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.80-impl-dec.patch
+
+ # Keep this comment and following mv, even in case ebuild does not need
+ # it: kept gtk-2.0.m4 in SRC_URI but you'll have to mv it before autoreconf
+ mv "${WORKDIR}"/gtk-2.0-for-mtr.m4 gtk-2.0.m4 #222909
+ AT_M4DIR="." eautoreconf
+}
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+ econf \
+ $(use_with gtk) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ if use !prefix ; then
+ fowners root:0 /usr/sbin/mtr
+ if use suid; then
+ fperms 4711 /usr/sbin/mtr
+ else
+ fperms 0710 /usr/sbin/mtr
+ fi
+ fi
+}