summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2005-01-05 23:25:01 +0000
committerScott W Taylor <swtaylor@gentoo.org>2005-01-05 23:25:01 +0000
commita52e89cfdbd80fa17d321edc0ea411d3d85800b2 (patch)
tree0e918d6139d49adf5ed473129cd72b97d8b8864e /net-analyzer/mrtg/mrtg-2.11.1.ebuild
parentMPlayer pre6 was missing docs upstream, adding an 'a' prefix to get the lates... (diff)
downloadgentoo-2-a52e89cfdbd80fa17d321edc0ea411d3d85800b2.tar.gz
gentoo-2-a52e89cfdbd80fa17d321edc0ea411d3d85800b2.tar.bz2
gentoo-2-a52e89cfdbd80fa17d321edc0ea411d3d85800b2.zip
bump
Diffstat (limited to 'net-analyzer/mrtg/mrtg-2.11.1.ebuild')
-rw-r--r--net-analyzer/mrtg/mrtg-2.11.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/mrtg/mrtg-2.11.1.ebuild b/net-analyzer/mrtg/mrtg-2.11.1.ebuild
new file mode 100644
index 000000000000..0ad2e8ba28e0
--- /dev/null
+++ b/net-analyzer/mrtg/mrtg-2.11.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mrtg/mrtg-2.11.1.ebuild,v 1.1 2005/01/05 23:25:01 swtaylor Exp $
+
+DESCRIPTION="A tool to monitor the traffic load on network-links"
+HOMEPAGE="http://ee-staff.ethz.ch/~oetiker/webtools/mrtg/"
+SRC_URI="http://ee-staff.ethz.ch/~oetiker/webtools/mrtg/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~ppc64 ~amd64 ~alpha"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-lang/perl
+ >=media-libs/gd-1.8.4"
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ dodir /usr/share/man
+ mv ${D}/usr/man/man1 ${D}/usr/share/man
+ rm -rf ${D}/usr/{man,doc}
+ dodoc ANNOUNCE COPYING CHANGES COPYRIGHT MANIFEST README THANKS
+ docinto txt ; dodoc doc/*.txt
+ cp -a contrib ${D}/usr/share/doc/${PF}/contrib
+ prepalldocs
+ docinto html ; dohtml -r doc/*.html images/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/mrtg.rc mrtg
+}