summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-20 10:46:22 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-20 10:46:22 +0000
commit190cb1a1418e275af6cf5790947891ad2955d2ab (patch)
treed6a0a6d87e1dd00b8cfbbeb1bad3a36c36a91435 /net-analyzer/linkchecker
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Ian ... (diff)
downloadgentoo-2-190cb1a1418e275af6cf5790947891ad2955d2ab.tar.gz
gentoo-2-190cb1a1418e275af6cf5790947891ad2955d2ab.tar.bz2
gentoo-2-190cb1a1418e275af6cf5790947891ad2955d2ab.zip
Version Bump
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/linkchecker')
-rw-r--r--net-analyzer/linkchecker/ChangeLog8
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.2.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 310339ec1fd5..745f31d9f98f 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.58 2011/08/14 11:57:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.59 2011/10/20 10:46:22 jlec Exp $
+
+*linkchecker-7.2 (20 Oct 2011)
+
+ 20 Oct 2011; Justin Lecher <jlec@gentoo.org> +linkchecker-7.2.ebuild,
+ metadata.xml:
+ Version Bump
*linkchecker-7.1 (14 Aug 2011)
diff --git a/net-analyzer/linkchecker/linkchecker-7.2.ebuild b/net-analyzer/linkchecker/linkchecker-7.2.ebuild
new file mode 100644
index 000000000000..f332772e697e
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.2.ebuild,v 1.1 2011/10/20 10:46:22 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/5.2-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ delete_gui() {
+ if ! use X; then
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ fi
+ }
+ python_execute_function -q delete_gui
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+ use bash-completion && dobashcompletion config/linkchecker-completion
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ echo ""
+ distutils_pkg_postinst
+}