summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-03-16 06:42:41 +0000
committerJeroen Roovers <jer@gentoo.org>2015-03-16 06:42:41 +0000
commitd8c73d52d359a26754d02ec05549db309fb6b310 (patch)
tree401e3220fba2421b89464454ccdf131ff392bdb1 /net-analyzer/libnasl
parentEAPI=5 (diff)
downloadgentoo-2-d8c73d52d359a26754d02ec05549db309fb6b310.tar.gz
gentoo-2-d8c73d52d359a26754d02ec05549db309fb6b310.tar.bz2
gentoo-2-d8c73d52d359a26754d02ec05549db309fb6b310.zip
Fix building with sys-devel/bison-3* (bug #485914, patch by Charlie Gehlin).
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/libnasl')
-rw-r--r--net-analyzer/libnasl/ChangeLog8
-rw-r--r--net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch29
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild10
3 files changed, 41 insertions, 6 deletions
diff --git a/net-analyzer/libnasl/ChangeLog b/net-analyzer/libnasl/ChangeLog
index 3d0409f1f275..c64829fe2639 100644
--- a/net-analyzer/libnasl/ChangeLog
+++ b/net-analyzer/libnasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/libnasl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.95 2014/10/12 10:21:12 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.96 2015/03/16 06:42:41 jer Exp $
+
+ 16 Mar 2015; Jeroen Roovers <jer@gentoo.org> libnasl-2.2.9-r1.ebuild,
+ +files/libnasl-2.2.9-bison3.patch:
+ Fix building with sys-devel/bison-3* (bug #485914, patch by Charlie Gehlin).
12 Oct 2014; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Remove short <longdescription>.
diff --git a/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch b/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch
new file mode 100644
index 000000000000..91f91fa38e09
--- /dev/null
+++ b/net-analyzer/libnasl/files/libnasl-2.2.9-bison3.patch
@@ -0,0 +1,29 @@
+--- a/nasl/nasl_grammar.y
++++ b/nasl/nasl_grammar.y
+@@ -1,4 +1,6 @@
+-%pure_parser
++%pure-parser
++%parse-param {naslctxt * parm}
++%lex-param {naslctxt * parm}
+ %expect 1
+ %{
+ /* Nessus Attack Scripting Language version 2
+@@ -31,7 +33,7 @@
+ #include "nasl_lex_ctxt.h"
+ #include "nasl_debug.h"
+
+-static void naslerror(const char *);
++static void naslerror(naslctxt *, const char *);
+ #define YYERROR_VERBOSE
+ %}
+
+@@ -465,8 +467,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
+-static void
+-naslerror(const char *s)
++static void naslerror(naslctxt *parm, const char *s)
+ {
+ fputs(s, stderr);
+ }
diff --git a/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild b/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild
index 913aa4347cd8..a9c034721879 100644
--- a/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild
+++ b/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild,v 1.5 2014/07/13 13:10:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.9-r1.ebuild,v 1.6 2015/03/16 06:42:41 jer Exp $
EAPI=5
-
inherit eutils toolchain-funcs
DESCRIPTION="A remote security scanner for Linux (libnasl)"
@@ -28,10 +27,13 @@ S=${WORKDIR}/${PN}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-openssl-1.patch \
- "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-bison3.patch
+
sed \
-e "/^LDFLAGS/s:$:${LDFLAGS}:g" \
-i nasl.tmpl.in || die
+
tc-export CC
}