summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-25 15:25:25 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-25 15:25:25 +0000
commit9b25de97834f251fed3d67c8f2cbc2082a43475b (patch)
tree0e4d862b607b259fe1610e9d979b6d06c2644025 /net-analyzer/ipcad
parentVersion bump. Added sqlite support. Closes #54069. (Manifest recommit) (diff)
downloadgentoo-2-9b25de97834f251fed3d67c8f2cbc2082a43475b.tar.gz
gentoo-2-9b25de97834f251fed3d67c8f2cbc2082a43475b.tar.bz2
gentoo-2-9b25de97834f251fed3d67c8f2cbc2082a43475b.zip
initial ebuild
Diffstat (limited to 'net-analyzer/ipcad')
-rw-r--r--net-analyzer/ipcad/ChangeLog11
-rw-r--r--net-analyzer/ipcad/Manifest4
-rw-r--r--net-analyzer/ipcad/files/digest-ipcad-3.6.21
-rw-r--r--net-analyzer/ipcad/files/ipcad.conf.d5
-rw-r--r--net-analyzer/ipcad/files/ipcad.init30
-rw-r--r--net-analyzer/ipcad/ipcad-3.6.2.ebuild41
-rw-r--r--net-analyzer/ipcad/metadata.xml6
7 files changed, 98 insertions, 0 deletions
diff --git a/net-analyzer/ipcad/ChangeLog b/net-analyzer/ipcad/ChangeLog
new file mode 100644
index 000000000000..ca8c6a41d627
--- /dev/null
+++ b/net-analyzer/ipcad/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/ipcad
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipcad/ChangeLog,v 1.1 2004/07/25 15:25:25 eldad Exp $
+
+*ipcad-3.6.2 (25 Jul 2004)
+
+ 25 Jul 2004; Eldad Zack <eldad@gentoo.org> +metadata.xml,
+ +files/ipcad.conf.d, +files/ipcad.init, +ipcad-3.6.2.ebuild:
+ Initial ebuild. Thanks to Shernakov Artem <artemsh@permonline.ru>. Closes
+ #53695.
+
diff --git a/net-analyzer/ipcad/Manifest b/net-analyzer/ipcad/Manifest
new file mode 100644
index 000000000000..bbbb02bea72a
--- /dev/null
+++ b/net-analyzer/ipcad/Manifest
@@ -0,0 +1,4 @@
+MD5 345b9ef201990c9c1f514d5c9d48613d ipcad-3.6.2.ebuild 992
+MD5 148698890032310e527de90805367134 files/ipcad.init 514
+MD5 3cffc04840194f2a426970366bce31c6 files/digest-ipcad-3.6.2 63
+MD5 ccd08900a3bd7420d99b2c4acff3b457 files/ipcad.conf.d 135
diff --git a/net-analyzer/ipcad/files/digest-ipcad-3.6.2 b/net-analyzer/ipcad/files/digest-ipcad-3.6.2
new file mode 100644
index 000000000000..ae4686de3553
--- /dev/null
+++ b/net-analyzer/ipcad/files/digest-ipcad-3.6.2
@@ -0,0 +1 @@
+MD5 93d60ec7f33017175ee22206ff3009d5 ipcad-3.6.2.tar.gz 166082
diff --git a/net-analyzer/ipcad/files/ipcad.conf.d b/net-analyzer/ipcad/files/ipcad.conf.d
new file mode 100644
index 000000000000..c75d7635061e
--- /dev/null
+++ b/net-analyzer/ipcad/files/ipcad.conf.d
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/pptpd
+
+# Any extra options you want to pass to pptpd
+# on start-up should be put here.
+IPCAD_OPTS="-drs"
diff --git a/net-analyzer/ipcad/files/ipcad.init b/net-analyzer/ipcad/files/ipcad.init
new file mode 100644
index 000000000000..547fe5d07253
--- /dev/null
+++ b/net-analyzer/ipcad/files/ipcad.init
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f /etc/ipcad.conf ] ; then
+ eerror "No /etc/ipcad.conf file exists!"
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ # Comment out the following line to get faster startups
+ checkconfig || return 1
+
+ ebegin "Starting ipcad"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ipcad -- ${IPCAD_OPTS} >/dev/null
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping ipcad"
+ start-stop-daemon --stop --quiet \
+ --pidfile=/var/ipcad/run/ipcad.pid --retry 20
+ eend $?
+}
diff --git a/net-analyzer/ipcad/ipcad-3.6.2.ebuild b/net-analyzer/ipcad/ipcad-3.6.2.ebuild
new file mode 100644
index 000000000000..37d4adf57ee1
--- /dev/null
+++ b/net-analyzer/ipcad/ipcad-3.6.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipcad/ipcad-3.6.2.ebuild,v 1.1 2004/07/25 15:25:25 eldad Exp $
+
+DESCRIPTION="IP Cisco Accounting Daemon"
+HOMEPAGE="http://ipcad.sourceforge.net/"
+SRC_URI="http://ipcad.sourceforge.net/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-libs/libpcap"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ sed -i -e "s/^chroot = \/adm\/tmp;/chroot = \/var\/ipcad;/" ipcad.conf.default
+ sed -i -e "s/^interface/#interface/" ipcad.conf.default
+ sed -i -e "s/^aggregate/#aggregate/" ipcad.conf.default
+ sed -i -e "s/^pidfile = ipcad.pid;/pidfile = \/run\/ipcad.pid;/" ipcad.conf.default
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL README TODO BUGS FAQ
+ dosbin ipcad
+
+ insinto /etc
+ insopts -m0600
+ newins ipcad.conf.default ipcad.conf
+
+ dodir /var/ipcad/run
+
+ doman ipcad.8 ipcad.conf.5
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ipcad.init ipcad
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/ipcad.conf.d ipcad
+}
diff --git a/net-analyzer/ipcad/metadata.xml b/net-analyzer/ipcad/metadata.xml
new file mode 100644
index 000000000000..2f3f975b84a4
--- /dev/null
+++ b/net-analyzer/ipcad/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>IP Cisco Accounting Daemon</longdescription>
+</pkgmetadata>