summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-07 06:47:44 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-07 06:47:44 +0000
commitc54b54ed1972536814c8f23e9e101cb1f05c5e53 (patch)
tree0540c3258f8b9edf2f6ab7d92d57071be657b3be /net-analyzer/goaccess/goaccess-0.8.5.ebuild
parentBump to latest aufs, genpatches and linux release; drop old (diff)
downloadgentoo-2-c54b54ed1972536814c8f23e9e101cb1f05c5e53.tar.gz
gentoo-2-c54b54ed1972536814c8f23e9e101cb1f05c5e53.tar.bz2
gentoo-2-c54b54ed1972536814c8f23e9e101cb1f05c5e53.zip
bump, wrt bug #530112, reset metadata.xml to substitute proxy maintainer
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'net-analyzer/goaccess/goaccess-0.8.5.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-0.8.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/goaccess/goaccess-0.8.5.ebuild b/net-analyzer/goaccess/goaccess-0.8.5.ebuild
new file mode 100644
index 000000000000..ca6b994242c0
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.8.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/goaccess-0.8.5.ebuild,v 1.1 2015/04/07 06:47:44 idella4 Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.io"
+SRC_URI="http://tar.goaccess.io/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="btree debug geoip bzip2 memhash unicode zlib"
+
+REQUIRED_USE="btree? ( !memhash )"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+ btree? ( dev-db/tokyocabinet )
+ memhash? ( dev-db/tokyocabinet )
+ zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Fix path to GeoIP bases in config
+ sed -e s':/usr/local:/usr:' -i config/goaccess.conf || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable geoip) \
+ $(use_enable bzip2 bzip) \
+ $(use_enable unicode utf8) \
+ $(use_enable zlib) \
+ $(use memhash && echo "--enable-tcb=memhash") \
+ $(use btree && echo "--enable-tcb=btree")
+
+ epatch_user
+}