summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-09-02 14:26:11 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-09-02 14:26:11 +0000
commitcfcdbd3932a1b1b9fb3843fc0907ae08287f18dc (patch)
tree250bafea6997cd222a5e2893ad99e99bbde07fad /media-video
parentStable on ppc wrt bug 190331 (diff)
downloadgentoo-2-cfcdbd3932a1b1b9fb3843fc0907ae08287f18dc.tar.gz
gentoo-2-cfcdbd3932a1b1b9fb3843fc0907ae08287f18dc.tar.bz2
gentoo-2-cfcdbd3932a1b1b9fb3843fc0907ae08287f18dc.zip
Version bumped. This among other stuff fixes layout when using Qt version 4.3.x, thanks to Daniel Pielmeier <daniel.pielmeier@googlemail.com>.
(Portage version: 2.1.3.7)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ttcut/ChangeLog8
-rw-r--r--media-video/ttcut/files/digest-ttcut-0.19.63
-rw-r--r--media-video/ttcut/ttcut-0.19.6.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/media-video/ttcut/ChangeLog b/media-video/ttcut/ChangeLog
index be0e775cc833..2a0ed05a4f2a 100644
--- a/media-video/ttcut/ChangeLog
+++ b/media-video/ttcut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ttcut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.8 2007/08/18 21:49:35 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.9 2007/09/02 14:26:11 zzam Exp $
+
+*ttcut-0.19.6 (02 Sep 2007)
+
+ 02 Sep 2007; Matthias Schwarzott <zzam@gentoo.org> +ttcut-0.19.6.ebuild:
+ Version bumped. This among other stuff fixes layout when using Qt version
+ 4.3.x, thanks to Daniel Pielmeier <daniel.pielmeier@googlemail.com>.
*ttcut-0.19.5-r1 (18 Aug 2007)
diff --git a/media-video/ttcut/files/digest-ttcut-0.19.6 b/media-video/ttcut/files/digest-ttcut-0.19.6
new file mode 100644
index 000000000000..d917a585bc16
--- /dev/null
+++ b/media-video/ttcut/files/digest-ttcut-0.19.6
@@ -0,0 +1,3 @@
+MD5 cb7774465b4e92fbdcde23de266a0929 ttcut-0.19.6.tar.gz 283977
+RMD160 80e0e29cf0a807a5603b1d2b28e0467c04c8577e ttcut-0.19.6.tar.gz 283977
+SHA256 e0f3f55fdcd67096de5588ddfb4a455cff731a9723923b34c283546c42c2ae11 ttcut-0.19.6.tar.gz 283977
diff --git a/media-video/ttcut/ttcut-0.19.6.ebuild b/media-video/ttcut/ttcut-0.19.6.ebuild
new file mode 100644
index 000000000000..6978f9a41555
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ttcut-0.19.6.ebuild,v 1.1 2007/09/02 14:26:11 zzam Exp $
+
+inherit eutils qt4
+
+DESCRIPTION="Tool for removing advertisements from recorded MPEG files"
+HOMEPAGE="http://ttcut.tritime.org/"
+SRC_URI="mirror://berlios/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.1)
+ >=media-libs/libmpeg2-0.4.0
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/transcode"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use media-video/transcode mjpeg ; then
+ eerror "In order to have encoding mode working with ttcut"
+ eerror "you need to recompile transcode with mjpeg USE flag enabled."
+ die "Recompile transcode with mjpeg USE flag enabled"
+ fi
+}
+
+src_compile() {
+ eqmake4 ttcut.pro -o Makefile.ttcut
+ emake -f Makefile.ttcut || die "emake failed"
+}
+
+src_install() {
+ dobin ttcut || die "Couldn't install ttcut"
+ make_desktop_entry ttcut TTCut "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make ttcut desktop entry"
+
+ dodoc AUTHORS BUGS CHANGELOG \
+ README.DE README.EN TODO || die "Couldn't install documentation"
+}