summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-02-14 23:12:55 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-02-14 23:12:55 +0000
commitcf8a661d8b2291995fe6a55917b37385cffe1eda (patch)
treeb8292a2909602a2f3a4c893424faa404e451598e /media-video
parentVersion bump; polkit support is added in this version, install the default po... (diff)
downloadgentoo-2-cf8a661d8b2291995fe6a55917b37385cffe1eda.tar.gz
gentoo-2-cf8a661d8b2291995fe6a55917b37385cffe1eda.tar.bz2
gentoo-2-cf8a661d8b2291995fe6a55917b37385cffe1eda.zip
version bump by Olivier Laurantin
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffdiaporama/ChangeLog9
-rw-r--r--media-video/ffdiaporama/ffdiaporama-2.1.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/media-video/ffdiaporama/ChangeLog b/media-video/ffdiaporama/ChangeLog
index a5de643e1cb2..35f9c779c090 100644
--- a/media-video/ffdiaporama/ChangeLog
+++ b/media-video/ffdiaporama/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffdiaporama
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.19 2013/12/29 08:47:28 xarthisius Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.20 2014/02/14 23:12:55 hasufell Exp $
+
+*ffdiaporama-2.1 (14 Feb 2014)
+
+ 14 Feb 2014; Julian Ospald <hasufell@gentoo.org> +ffdiaporama-2.1.ebuild:
+ version bump by Olivier Laurantin
29 Dec 2013; Kacper Kowalik <xarthisius@gentoo.org> -ffdiaporama-2.0.ebuild:
Drop old ebuild as sources were removed upstream
diff --git a/media-video/ffdiaporama/ffdiaporama-2.1.ebuild b/media-video/ffdiaporama/ffdiaporama-2.1.ebuild
new file mode 100644
index 000000000000..2e6b12eb6e8b
--- /dev/null
+++ b/media-video/ffdiaporama/ffdiaporama-2.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils fdo-mime gnome2-utils qt4-r2
+
+BIN_PV=${PV}.2014.0209
+RSC_PV=${PV}.2014.0209
+TMT_PV=1.0.2014.0125
+OPENCLI_PV=0.18
+OPENCLI_P=openclipart-${OPENCLI_PV}
+DESCRIPTION="Movie creator from photos and video clips"
+HOMEPAGE="http://ffdiaporama.tuxfamily.org"
+SRC_URI="http://ffdiaporama.tuxfamily.org/script/GetPackage.php?f=${PN}_bin_${BIN_PV}.tar.gz -> ${PN}_bin_${BIN_PV}.tar.gz
+ http://ffdiaporama.tuxfamily.org/script/GetPackage.php?f=${PN}_rsc_${RSC_PV}.tar.gz -> ${PN}_rsc_${RSC_PV}.tar.gz
+ openclipart? ( http://openclipart.org/downloads/${OPENCLI_PV}/${OPENCLI_P}-svgonly.tar.bz2 )
+ texturemate? ( http://ffdiaporama.tuxfamily.org/script/GetPackage.php?f=${PN}_texturemate_${TMT_PV}.tar.gz -> ${PN}_texturemate_${TMT_PV}.tar.gz )"
+
+LICENSE="GPL-2
+ openclipart? ( CC0-1.0 )
+ texturemate? ( CC-BY-3.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openclipart texturemate"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qthelp:4
+ dev-qt/qtsql:4[sqlite]
+ dev-qt/qtsvg:4
+ media-gfx/exiv2
+ media-libs/libsdl[audio]
+ media-libs/taglib
+ !<media-video/ffmpeg-1.2:0
+ virtual/ffmpeg[encode]"
+DEPEND="${RDEPEND}"
+
+DOCS=( authors.txt )
+
+S="${WORKDIR}/ffDiaporama"
+
+src_prepare() {
+ echo "SUBDIRS += ../ffDiaporama_rsc" >> ffDiaporama.pro || die
+ if use texturemate; then
+ echo "SUBDIRS += ../ffDiaporama_texturemate" >> ffDiaporama.pro || die
+ fi
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon -s 32 ffdiaporama.png
+ if use openclipart; then
+ dodir /usr/share/ffDiaporama/clipart/openclipart
+ cd "${WORKDIR}"/${OPENCLI_P}-svgonly/clipart || die
+ find . -type d -maxdepth 1 -not -name . -exec cp -R '{}' "${D}"/usr/share/ffDiaporama/clipart/openclipart \; || die
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}