summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-12 10:18:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-12 10:18:12 +0000
commit95ae4388d03b934a2eac97ed6da32c3f5c91f04b (patch)
treef77b366e5b18cfd36ac8cbce9909994b9c3f7b23 /media-video
parentkeyword ~x86-fbsd, bug #313309 (diff)
downloadgentoo-2-95ae4388d03b934a2eac97ed6da32c3f5c91f04b.tar.gz
gentoo-2-95ae4388d03b934a2eac97ed6da32c3f5c91f04b.tar.bz2
gentoo-2-95ae4388d03b934a2eac97ed6da32c3f5c91f04b.zip
version bump, by hitachi <mail@konstantinhansen.de>, bug #306827
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog9
-rw-r--r--media-video/clive/clive-2.2.11.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 9cfcf0d8ae9a..274ed1d7ef5e 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.60 2009/11/25 10:23:22 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.61 2010/04/12 10:18:12 aballier Exp $
+
+*clive-2.2.11 (12 Apr 2010)
+
+ 12 Apr 2010; Alexis Ballier <aballier@gentoo.org> +clive-2.2.11.ebuild:
+ version bump, by hitachi <mail@konstantinhansen.de>, bug #306827
25 Nov 2009; Markus Meier <maekke@gentoo.org> clive-2.2.6.ebuild:
amd64 stable, bug #284544
diff --git a/media-video/clive/clive-2.2.11.ebuild b/media-video/clive/clive-2.2.11.ebuild
new file mode 100644
index 000000000000..b5a3fdf28e90
--- /dev/null
+++ b/media-video/clive/clive-2.2.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.11.ebuild,v 1.1 2010/04/12 10:18:12 aballier Exp $
+
+EAPI=2
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://clive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND=""
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}