summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-02-12 13:15:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-02-12 13:15:46 +0000
commit928fa98c366230e8cef43df06f4ab4dc92e40176 (patch)
treea9e176c351fb12eaa858a2ccc686363c9b9d4796 /media-video
parentStable for HPPA (bug #492178). (diff)
downloadgentoo-2-928fa98c366230e8cef43df06f4ab4dc92e40176.tar.gz
gentoo-2-928fa98c366230e8cef43df06f4ab4dc92e40176.tar.bz2
gentoo-2-928fa98c366230e8cef43df06f4ab4dc92e40176.zip
add opengl useflag
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 7bbccea015be..9d219a5f0fe4 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.709 2014/02/12 12:48:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.710 2014/02/12 13:15:46 aballier Exp $
+
+ 12 Feb 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ add opengl useflag
12 Feb 2014; Alexis Ballier <aballier@gentoo.org> ffmpeg-2.1.3.ebuild,
ffmpeg-9999.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 158e97ec6578..53f1b54b06af 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.145 2014/02/12 12:48:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.146 2014/02/12 13:15:46 aballier Exp $
EAPI="5"
@@ -43,10 +43,10 @@ IUSE="
aac aacplus alsa amr amrenc bindist bluray +bzip2 cdio celt
cpudetection debug doc +encode examples faac fdk flite fontconfig frei0r
gme gnutls gsm +hardcoded-tables +iconv iec61883 ieee1394 jack jpeg2k
- ladspa libass libcaca libsoxr libv4l modplug mp3 +network openal openssl opus
- oss pic pulseaudio quvi rtmp schroedinger sdl speex ssh static-libs test theora
- threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack X x264 xvid
- +zlib zvbi
+ ladspa libass libcaca libsoxr libv4l modplug mp3 +network openal opengl
+ openssl opus oss pic pulseaudio quvi rtmp schroedinger sdl speex ssh
+ static-libs test theora threads truetype twolame v4l vaapi vdpau vorbis vpx
+ wavpack X x264 xvid +zlib zvbi
"
ARM_CPU_FEATURES="armv5te armv6 armv6t2 neon armvfp:vfp"
@@ -112,6 +112,7 @@ RDEPEND="
libv4l? ( media-libs/libv4l )
modplug? ( media-libs/libmodplug )
openal? ( >=media-libs/openal-1.1 )
+ opengl? ( virtual/opengl )
openssl? ( dev-libs/openssl )
opus? ( media-libs/opus )
pulseaudio? ( media-sound/pulseaudio )
@@ -197,7 +198,7 @@ src_configure() {
fi
# libavdevice options
- ffuse="${ffuse} cdio:libcdio iec61883:libiec61883 ieee1394:libdc1394 libcaca openal"
+ ffuse="${ffuse} cdio:libcdio iec61883:libiec61883 ieee1394:libdc1394 libcaca openal opengl"
# Indevs
use v4l || myconf="${myconf} --disable-indev=v4l2 --disable-outdev=v4l2"