summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-06-29 22:51:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-06-29 22:51:38 +0000
commit8f3e33d843c7c7ec4b58942dc20c8e854adb1506 (patch)
treed1e73f2d655846c1385d6f3b1ddf4c95fb81ae6d /media-video/subtitleeditor
parentSparc stable, bug #275875. (diff)
downloadgentoo-2-8f3e33d843c7c7ec4b58942dc20c8e854adb1506.tar.gz
gentoo-2-8f3e33d843c7c7ec4b58942dc20c8e854adb1506.tar.bz2
gentoo-2-8f3e33d843c7c7ec4b58942dc20c8e854adb1506.zip
Version bump. Add gst-plugins-pango, bug #274830. Better spellchecking integration, bug fixes and translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog9
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.33.0.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
index adbb70718c52..687ff58dab3e 100644
--- a/media-video/subtitleeditor/ChangeLog
+++ b/media-video/subtitleeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/subtitleeditor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.2 2009/05/23 13:10:45 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.3 2009/06/29 22:51:38 eva Exp $
+
+*subtitleeditor-0.33.0 (30 Jun 2009)
+
+ 30 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +subtitleeditor-0.33.0.ebuild:
+ Version bump. Add gst-plugins-pango, bug #274830. Better spellchecking
+ integration, bug fixes and translation updates.
*subtitleeditor-0.31.0 (23 May 2009)
diff --git a/media-video/subtitleeditor/subtitleeditor-0.33.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.33.0.ebuild
new file mode 100644
index 000000000000..cf9ddf85d572
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.33.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.33.0.ebuild,v 1.1 2009/06/29 22:51:38 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="GTK+2 subtitle editing tool."
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-cpp/gtkmm-2.12
+ >=dev-cpp/glibmm-2.16.3
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/libxmlpp-2.20
+ >=app-text/enchant-1.1.0
+ opengl? ( >=dev-cpp/gtkglextmm-1.2 )
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-pango-0.10
+ app-text/iso-codes"
+# gst-plugins-pango needed for text overlay
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+src_configure() {
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # USE="debug" seems to turn on some debug path
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl gl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If ${PN} doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}