summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-03-13 21:43:37 +0000
committerThilo Bangert <bangert@gentoo.org>2009-03-13 21:43:37 +0000
commit423d509524343225ed629d1dcc74b4834dd1727c (patch)
tree5ca188509d0232923b5ee0c43d08fe47cee60c13 /media-video/nvclock
parentCleanup (diff)
downloadgentoo-2-423d509524343225ed629d1dcc74b4834dd1727c.tar.gz
gentoo-2-423d509524343225ed629d1dcc74b4834dd1727c.tar.bz2
gentoo-2-423d509524343225ed629d1dcc74b4834dd1727c.zip
version bump - bug #260586 - thanks Ishan Arora and Alexander Bezrukov
(Portage version: 2.2_rc24/cvs/Linux i686)
Diffstat (limited to 'media-video/nvclock')
-rw-r--r--media-video/nvclock/ChangeLog9
-rw-r--r--media-video/nvclock/nvclock-0.8_beta4.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/media-video/nvclock/ChangeLog b/media-video/nvclock/ChangeLog
index 4768aea2f962..6cc5c70df17b 100644
--- a/media-video/nvclock/ChangeLog
+++ b/media-video/nvclock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/nvclock
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/ChangeLog,v 1.25 2008/06/04 18:36:44 flameeyes Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/ChangeLog,v 1.26 2009/03/13 21:43:37 bangert Exp $
+
+*nvclock-0.8_beta4 (13 Mar 2009)
+
+ 13 Mar 2009; Thilo Bangert <bangert@gentoo.org> +nvclock-0.8_beta4.ebuild:
+ version bump - bug #260586
04 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
nvclock-0.8_beta2.ebuild:
diff --git a/media-video/nvclock/nvclock-0.8_beta4.ebuild b/media-video/nvclock/nvclock-0.8_beta4.ebuild
new file mode 100644
index 000000000000..245c7efc7af6
--- /dev/null
+++ b/media-video/nvclock/nvclock-0.8_beta4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvclock/nvclock-0.8_beta4.ebuild,v 1.1 2009/03/13 21:43:37 bangert Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}${PV/_beta/b}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="NVIDIA Overclocking Utility"
+HOMEPAGE="http://www.linuxhardware.org/nvclock/"
+SRC_URI="http://www.linuxhardware.org/nvclock/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="gtk qt3"
+
+RDEPEND="virtual/libc
+ gtk? ( =x11-libs/gtk+-2* )
+ qt3? ( =x11-libs/qt-3* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch to fix broken autoconf macro "--with-qt-libs" needed below
+ # Submitted upstream, hopefully fixed in a later version
+ use qt3 && epatch "${FILESDIR}"/nvclock_acinclude_qtlibs.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ # Needed to ensure it compiles against Qt3 rather than Qt4
+ export QTDIR=/usr/qt/3
+ export MOC=${QTDIR}/bin/moc
+
+ local myconf
+
+ # Qt3 package doesn't install symlinks from ${QTDIR}/lib64 to ${QTDIR}/lib
+ use amd64 && myconf="${myconf} --with-qt-libs=${QTDIR}/lib64"
+
+ ./configure $(use_enable qt3 qt) $(use_enable gtk) ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall || die
+ dodoc AUTHORS README
+
+ newinitd "${FILESDIR}"/nvclock_initd nvclock
+ newconfd "${FILESDIR}"/nvclock_confd nvclock
+}
+
+pkg_postinst() {
+ elog "To enable card overclocking at startup, edit your /etc/conf.d/nvclock"
+ elog "accordingly and then run: rc-update add nvclock default"
+}