summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-29 20:55:49 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-29 20:55:49 +0000
commitbe737435c52c5c1e3c154da8e2b1244b04a1e808 (patch)
treea16bf4d90697132a00f5583877e0a41213e62860 /media-video/griffith
parentfix format of patch. (diff)
downloadgentoo-2-be737435c52c5c1e3c154da8e2b1244b04a1e808.tar.gz
gentoo-2-be737435c52c5c1e3c154da8e2b1244b04a1e808.tar.bz2
gentoo-2-be737435c52c5c1e3c154da8e2b1244b04a1e808.zip
Version bump
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog8
-rw-r--r--media-video/griffith/files/digest-griffith-0.9_rc16
-rw-r--r--media-video/griffith/griffith-0.9_rc1.ebuild64
3 files changed, 77 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index c684d3db6ed5..dcb43e1aac3d 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.1 2006/09/27 21:21:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.2 2006/12/29 20:55:49 dev-zero Exp $
+
+*griffith-0.9_rc1 (29 Dec 2006)
+
+ 29 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+ +griffith-0.9_rc1.ebuild:
+ Version bump
*griffith-0.6.2 (27 Sep 2006)
diff --git a/media-video/griffith/files/digest-griffith-0.9_rc1 b/media-video/griffith/files/digest-griffith-0.9_rc1
new file mode 100644
index 000000000000..83e58cf85a52
--- /dev/null
+++ b/media-video/griffith/files/digest-griffith-0.9_rc1
@@ -0,0 +1,6 @@
+MD5 0058d725df61afeecad35382373cffe8 griffith-0.9-rc1.tar.gz 632574
+RMD160 d193b39bae0b76a0b7383d1323524730b46d208d griffith-0.9-rc1.tar.gz 632574
+SHA256 1cd67d51498256cdc637f7d0f2ec990c6f57720b2d364ea7125754fd0277b7df griffith-0.9-rc1.tar.gz 632574
+MD5 7d76d1db9f3eb9f19d41b187591e3ba5 griffith-extra-artwork-0.6.2.tar.gz 102336
+RMD160 8c9774f8a739753a1a7c419e3d896753465989bf griffith-extra-artwork-0.6.2.tar.gz 102336
+SHA256 d66f0c7be51cc65608ba43d4ef07959e4ec59e17e2f7aee5ffd226c4c33aa028 griffith-extra-artwork-0.6.2.tar.gz 102336
diff --git a/media-video/griffith/griffith-0.9_rc1.ebuild b/media-video/griffith/griffith-0.9_rc1.ebuild
new file mode 100644
index 000000000000..f4645ed35fa6
--- /dev/null
+++ b/media-video/griffith/griffith-0.9_rc1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9_rc1.ebuild,v 1.1 2006/12/29 20:55:49 dev-zero Exp $
+
+inherit python
+
+ARTWORK_PV=0.6.2
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.vasconunes.net/"
+SRC_URI="http://download.berlios.de/griffith/${P/_/-}.tar.gz
+ http://download.berlios.de/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc spell"
+
+RDEPEND="dev-python/imaging
+ >=dev-python/pygtk-2.6.1
+ >=dev-python/pysqlite-2.0
+ >=dev-python/sqlalchemy-0.3
+ >=dev-python/reportlab-1.19
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+# No, this is not a joke! they really name the directory "griffith-0.9~rc1"
+S="${WORKDIR}/${P/_/~}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/docbook2x-man/docbook2man.pl/' \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/*/Makefile || die "sed failed"
+ sed -i \
+ -e 's/latin1/iso-8859-1/' \
+ docs/en/*.xml || die "sed failed"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/share/${PN}/lib
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/share/${PN}/lib
+}