summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2007-02-20 12:13:57 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2007-02-20 12:13:57 +0000
commit80f1f8b8b7cb6312906b568fe67fd818323cd2fa (patch)
treebae3c694c119cb44ceb99964150352d58b73f608 /media-video/flumotion
parentUse atheros-hal license for truedfx bug 146319 (diff)
downloadgentoo-2-80f1f8b8b7cb6312906b568fe67fd818323cd2fa.tar.gz
gentoo-2-80f1f8b8b7cb6312906b568fe67fd818323cd2fa.tar.bz2
gentoo-2-80f1f8b8b7cb6312906b568fe67fd818323cd2fa.zip
version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog10
-rw-r--r--media-video/flumotion/files/digest-flumotion-0.4.13
-rw-r--r--media-video/flumotion/flumotion-0.4.1.ebuild103
3 files changed, 114 insertions, 2 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
index 028fd2b0acac..15ecca69ecab 100644
--- a/media-video/flumotion/ChangeLog
+++ b/media-video/flumotion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/flumotion
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.10 2006/06/07 14:23:44 zaheerm Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.11 2007/02/20 12:13:57 zaheerm Exp $
+
+*flumotion-0.4.1 (20 Feb 2007)
+
+ 20 Feb 2007; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +flumotion-0.4.1.ebuild:
+ version bump
07 Jun 2006; <zaheer@gentoo.org> flumotion-0.2.1.ebuild:
fix LINGUAS issue, flumotion requires all linguas to be installed
diff --git a/media-video/flumotion/files/digest-flumotion-0.4.1 b/media-video/flumotion/files/digest-flumotion-0.4.1
new file mode 100644
index 000000000000..9ebcb03be293
--- /dev/null
+++ b/media-video/flumotion/files/digest-flumotion-0.4.1
@@ -0,0 +1,3 @@
+MD5 85563f1167a3265cf61c8886c318dda7 flumotion-0.4.1.tar.bz2 957882
+RMD160 94148eaeed10a77c64a0ae09727d3475519d9412 flumotion-0.4.1.tar.bz2 957882
+SHA256 a24640d8ca9c485d7611880193f18e5ae62af07e3b9464904f3602277f1d4097 flumotion-0.4.1.tar.bz2 957882
diff --git a/media-video/flumotion/flumotion-0.4.1.ebuild b/media-video/flumotion/flumotion-0.4.1.ebuild
new file mode 100644
index 000000000000..1f0df5f9cf0b
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.4.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.4.1.ebuild,v 1.1 2007/02/20 12:13:57 zaheerm Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.fluendo.com"
+SRC_URI="http://www.flumotion.net/src/flumotion/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="v4l speex jpeg dv"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ >=gnome-base/libglade-2
+ >=media-libs/gstreamer-0.10.11
+ >=media-libs/gst-plugins-base-0.10.11
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-theora-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10*
+ =media-plugins/gst-plugins-libpng-0.10*
+ =dev-python/gst-python-0.10*
+ v4l? ( =media-plugins/gst-plugins-v4l-0.10* )
+ speex? ( =media-plugins/gst-plugins-speex-0.10* )
+ dv? ( =media-plugins/gst-plugins-dv-0.10*
+ =media-plugins/gst-plugins-raw1394-0.10* )
+ >=dev-python/pygtk-2.8.6
+ >=dev-python/twisted-2.0
+ >=dev-python/twisted-web-0.5.0-r1
+ >=dev-python/twisted-names-0.2.0
+ dev-python/imaging
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ LICENCE.Flumotion LICENCE.GPL \
+ NEWS README TODO"
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ unset LINGUAS
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ econf --disable-install-schemas --localstatedir=/var || die
+
+ emake || die
+ # fix ${exec_prefix} not being expanded
+ cd ${S}/bin
+ cp flumotion-manager flumotion-manager.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-manager.orig \
+ > flumotion-manager
+ cp flumotion-worker flumotion-worker.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-worker.orig \
+ > flumotion-worker
+ cp flumotion-admin flumotion-admin.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-admin.orig \
+ > flumotion-admin
+}
+
+src_install() {
+ einstall
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ cd ${S}/conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+
+ insinto /etc/flumotion
+ doins default.pem
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/flumotion-init-0.2.0 flumotion
+
+ keepdir /var/run/flumotion
+ keepdir /var/log/flumotion
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion ${dir}
+ chmod -R 755 ${dir}
+ done
+}