summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-04 17:15:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-04 17:15:58 +0000
commitc2df92ec60117d9ee0bb1671cf1cbca58fe2c230 (patch)
tree6fa1c3f32239021e6337669a8ee3adf581a02218 /media-video/clive
parentversion bump (bug #365957) submitted by Locke Shinseiko (diff)
downloadgentoo-2-c2df92ec60117d9ee0bb1671cf1cbca58fe2c230.tar.gz
gentoo-2-c2df92ec60117d9ee0bb1671cf1cbca58fe2c230.tar.bz2
gentoo-2-c2df92ec60117d9ee0bb1671cf1cbca58fe2c230.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.25.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 34d0e9012dfe..d611f5a6af66 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.68 2011/04/19 19:32:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.69 2011/05/04 17:15:58 aballier Exp $
+
+*clive-2.2.25 (04 May 2011)
+
+ 04 May 2011; Alexis Ballier <aballier@gentoo.org> +clive-2.2.25.ebuild:
+ version bump
*clive-2.2.24 (19 Apr 2011)
diff --git a/media-video/clive/clive-2.2.25.ebuild b/media-video/clive/clive-2.2.25.ebuild
new file mode 100644
index 000000000000..028d72f0ef9b
--- /dev/null
+++ b/media-video/clive/clive-2.2.25.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.25.ebuild,v 1.1 2011/05/04 17:15:58 aballier Exp $
+
+EAPI=2
+
+inherit perl-app versionator
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND="test? ( dev-perl/Test-Pod
+ ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}