summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-01-06 18:09:04 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-01-06 18:09:04 +0000
commit099bac1af38136b17e11ffe88cdcaa8bc1f4a231 (patch)
treeba1c451a48724a9bf2f37232929ef8ffbfcdeffd /media-tv/w_scan
parentarm stable, bug #449744 (diff)
downloadgentoo-2-099bac1af38136b17e11ffe88cdcaa8bc1f4a231.tar.gz
gentoo-2-099bac1af38136b17e11ffe88cdcaa8bc1f4a231.tar.bz2
gentoo-2-099bac1af38136b17e11ffe88cdcaa8bc1f4a231.zip
bump, fixed compile with dvb api 5.8
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-tv/w_scan')
-rw-r--r--media-tv/w_scan/ChangeLog9
-rw-r--r--media-tv/w_scan/w_scan-20121111.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/media-tv/w_scan/ChangeLog b/media-tv/w_scan/ChangeLog
index 1d9f83a16faa..e81f8cd39059 100644
--- a/media-tv/w_scan/ChangeLog
+++ b/media-tv/w_scan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/w_scan
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.33 2012/09/23 08:03:53 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.34 2013/01/06 18:09:04 hd_brummy Exp $
+
+*w_scan-20121111 (06 Jan 2013)
+
+ 06 Jan 2013; Joerg Bornkessel <hd_brummy@gentoo.org> +w_scan-20121111.ebuild:
+ bump, fixed compile with dvb api 5.8
23 Sep 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> w_scan-20120525.ebuild:
x86 stable wrt bug #429140
diff --git a/media-tv/w_scan/w_scan-20121111.ebuild b/media-tv/w_scan/w_scan-20121111.ebuild
new file mode 100644
index 000000000000..b16b09cdb77a
--- /dev/null
+++ b/media-tv/w_scan/w_scan-20121111.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/w_scan-20121111.ebuild,v 1.1 2013/01/06 18:09:04 hd_brummy Exp $
+
+EAPI="5"
+
+DESCRIPTION="Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies and modulations"
+HOMEPAGE="http://wirbel.htpc-forum.de/w_scan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=">=virtual/linuxtv-dvb-headers-5.3"
+RDEPEND=""
+
+src_prepare() {
+ # support dvb api 5.8
+ if has_version ">=virtual/linuxtv-dvb-headers-5.8"; then
+ sed -e "s:DTV_DVBT2_PLP_ID:DTV_STREAM_ID:" -i scan.c
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README
+
+ if use doc; then
+ dodoc doc/README.file_formats doc/README_VLC_DVB
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/rotor.conf
+ fi
+}