summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-10-15 22:52:40 +0000
committerBrian Jackson <iggy@gentoo.org>2004-10-15 22:52:40 +0000
commit9619e9364e02b54e7261fc40b3b468209e38325f (patch)
tree235202fd30b1822a325cb8ede122d08e4cfa606d /media-tv/ivtv/ivtv-0.2.0_rc1.ebuild
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-9619e9364e02b54e7261fc40b3b468209e38325f.tar.gz
gentoo-2-9619e9364e02b54e7261fc40b3b468209e38325f.tar.bz2
gentoo-2-9619e9364e02b54e7261fc40b3b468209e38325f.zip
version bump
Diffstat (limited to 'media-tv/ivtv/ivtv-0.2.0_rc1.ebuild')
-rw-r--r--media-tv/ivtv/ivtv-0.2.0_rc1.ebuild113
1 files changed, 113 insertions, 0 deletions
diff --git a/media-tv/ivtv/ivtv-0.2.0_rc1.ebuild b/media-tv/ivtv/ivtv-0.2.0_rc1.ebuild
new file mode 100644
index 000000000000..3bb1fcee9efb
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.2.0_rc1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.2.0_rc1.ebuild,v 1.1 2004/10/15 22:52:40 iggy Exp $
+
+# TODO
+# the "Gentoo way" is to use /usr/src/linux, not the running kernel
+# removed ptune*.pl, need to make a seperate package for it
+# check for other msp3400 modules
+# add a few notes to the postinst output about what's needed (bttv/tuner, etc.)
+
+inherit eutils
+
+DESCRIPTION="ivtv driver for Hauppauge PVR[23]50 cards"
+HOMEPAGE="http://ivtv.sourceforge.net"
+
+# stupidly named tarballs
+MY_P="${P/_/-}c"
+
+
+SRC_URI="http://67.18.1.101/~ckennedy/ivtv/${MY_P}.tgz
+ http://hauppauge.lightpath.net/software/pvr250/pvr250_18a_inf.zip"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+[ "`echo ${KV} | cut -f2 -d.`" == 6 ] && SANDBOX_DISABLED="1"
+
+IUSE="lirc"
+
+DEPEND="lirc? ( app-misc/lirc )"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+}
+
+src_compile() {
+ set_arch_to_kernel
+
+ cd ${WORKDIR}/${MY_P}/driver
+ make || die "build of driver failed"
+
+ cd ${WORKDIR}/${MY_P}/utils
+ make || die "build of utils failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_P}/utils
+ cp ${DISTDIR}/pvr250_18a_inf.zip .
+ dodir /lib/modules
+ touch ${D}/lib/modules/ivtv-fw-{enc,dec}.bin
+ ./ivtvfwextract.pl pvr250_18a_inf.zip \
+ ${D}/lib/modules/ivtv-fw-enc.bin \
+ ${D}/lib/modules/ivtv-fw-dec.bin
+
+ cd ${WORKDIR}/${MY_P}
+ dodoc README doc/*
+
+ cd ${WORKDIR}/${MY_P}/utils
+ newbin test_ioctl ivtvctl
+ newbin encoder ivtv-encoder
+ newbin fwapi ivtv-fwapi
+ newbin radio ivtv-radio
+ newbin vbi ivtv-vbi
+ newbin mpegindex ivtv-mpegindex
+ dobin ivtvfbctl ivtvplay
+ newdoc README README.utils
+ dodoc README.mythtv-ivtv README.radio README.vbi zvbi.diff
+ dodoc lircd-g.conf lircd.conf lircrc
+
+ cd ${WORKDIR}/${MY_P}/driver
+ make DESTDIR=${D} install || die "installation of driver failed"
+
+ set_arch_to_portage
+
+ dodir /etc/modules.d
+
+ echo "alias char-major-81 videodev" >>${D}/etc/modules.d/ivtv
+ echo "alias char-major-81-0 ivtv" >>${D}/etc/modules.d/ivtv
+
+ if [ `has app-misc/lirc` ] || use lirc ; then
+ echo "alias char-major-61 lirc_i2c" >> ${D}/etc/modules.d/ivtv
+ echo "add above ivtv lirc_dev lirc_i2c" >> ${D}/etc/modules.d/ivtv
+ else
+ einfo "Not enabling lirc support. emerge lirc to get it."
+ fi
+
+}
+
+pkg_postinst() {
+ depmod -ae
+
+ einfo "You now have the driver for the Hauppauge PVR-[23]50 cards."
+ einfo "Add ivtv to /etc/modules.autoload.d/kernel-2.X"
+ einfo "You'll now need an application to watch tv. "
+ einfo "To get the ir remote working, you'll need to emerge lirc"
+ einfo "with the following env variable set:"
+ einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61"
+ einfo " --with-port=none --with-irq=none\""
+ einfo "see http://ivtv.sourceforge.net for more info"
+ echo
+ einfo "to use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ echo
+ einfo "you'll also need to add 'LIRCD_OPTS=\"--device=/dev/lirc/0\"' to /etc/conf.d/lircd"
+ echo
+ einfo "The ptune* scripts have moved to media-tv/ivtv-ptune, emerge that to use those scripts"
+
+ if [ -f "/lib/modules/`uname -r`/kernel/drivers/media/video/msp3400.ko" ] ; then
+ ewarn "You have the msp3400 module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run depmod -ae again"
+ fi
+}