summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-06 21:41:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-06 21:41:05 +0000
commit6681f2e9226abd05fa4642aac79a5a32d40e06b9 (patch)
treed385668b2f299a2e7d65a03d559fab92563e86d5 /media-sound
parentHandle csr/crt files with openssl. (diff)
downloadgentoo-2-6681f2e9226abd05fa4642aac79a5a32d40e06b9.tar.gz
gentoo-2-6681f2e9226abd05fa4642aac79a5a32d40e06b9.tar.bz2
gentoo-2-6681f2e9226abd05fa4642aac79a5a32d40e06b9.zip
fix build with ffmpeg-2, bug #478080
(Portage version: 2.2.0_alpha194/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/ChangeLog6
-rw-r--r--media-sound/sox/files/sox-14.4.1-ffmpeg2.patch16
-rw-r--r--media-sound/sox/sox-14.4.1.ebuild9
3 files changed, 29 insertions, 2 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 4fa0899b927c..3f75dd93c918 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.153 2013/03/10 09:52:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.154 2013/08/06 21:41:05 aballier Exp $
+
+ 06 Aug 2013; Alexis Ballier <aballier@gentoo.org> sox-14.4.1.ebuild,
+ +files/sox-14.4.1-ffmpeg2.patch:
+ fix build with ffmpeg-2, bug #478080
10 Mar 2013; Alexis Ballier <aballier@gentoo.org> -sox-14.3.2-r1.ebuild,
-files/sox-14.3.2-ffmpeg.patch, -files/sox-14.3.2-uclibc.patch,
diff --git a/media-sound/sox/files/sox-14.4.1-ffmpeg2.patch b/media-sound/sox/files/sox-14.4.1-ffmpeg2.patch
new file mode 100644
index 000000000000..2c359363fcf8
--- /dev/null
+++ b/media-sound/sox/files/sox-14.4.1-ffmpeg2.patch
@@ -0,0 +1,16 @@
+Index: sox-14.4.1/src/ffmpeg.c
+===================================================================
+--- sox-14.4.1.orig/src/ffmpeg.c
++++ sox-14.4.1/src/ffmpeg.c
+@@ -57,6 +57,11 @@
+ #define PKT_FLAG_KEY AV_PKT_FLAG_KEY
+ #endif
+
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE (192000 * 4)
++#endif
++
++
+ /* Private data for ffmpeg files */
+ typedef struct {
+ int audio_index;
diff --git a/media-sound/sox/sox-14.4.1.ebuild b/media-sound/sox/sox-14.4.1.ebuild
index 2dfe568752ff..d1ca0d8a5124 100644
--- a/media-sound/sox/sox-14.4.1.ebuild
+++ b/media-sound/sox/sox-14.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.4.1.ebuild,v 1.9 2013/03/09 13:35:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.4.1.ebuild,v 1.10 2013/08/06 21:41:05 aballier Exp $
EAPI=4
inherit eutils flag-o-matic autotools
@@ -45,6 +45,13 @@ src_prepare() {
"${FILESDIR}"/${PN}-14.4.0-ffmpeg.patch \
"${FILESDIR}"/${PN}-14.4.0-avcodec54.patch \
"${FILESDIR}"/${PN}-14.4.0-libav-9.patch
+
+ if has_version '>=media-video/ffmpeg-2' ; then
+ epatch "${FILESDIR}"/${PN}-14.4.1-ffmpeg2.patch
+ sed -i -e 's/ CODEC_ID/ AV_CODEC_ID/g' \
+ -e 's/ CodecID/ AVCodecID/g' \
+ src/ffmpeg.c || die
+ fi
eautoreconf
}