summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-05-09 23:48:34 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-05-09 23:48:34 +0000
commit6312d05401790568ede7f0bbca68efec0121d236 (patch)
treeb8dc7298a74217b7eeb01923a409f4987a52f935 /media-sound
parentDiff to make mpg123 compile on gentoo-sparc (diff)
downloadgentoo-2-6312d05401790568ede7f0bbca68efec0121d236.tar.gz
gentoo-2-6312d05401790568ede7f0bbca68efec0121d236.tar.bz2
gentoo-2-6312d05401790568ede7f0bbca68efec0121d236.zip
Added patch to make compile on gentoo-sparc (no other impact)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpg123/mpg123-0.59r-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-sound/mpg123/mpg123-0.59r-r1.ebuild b/media-sound/mpg123/mpg123-0.59r-r1.ebuild
index 560c3466b201..b8ea99b4f86f 100644
--- a/media-sound/mpg123/mpg123-0.59r-r1.ebuild
+++ b/media-sound/mpg123/mpg123-0.59r-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Id: mpg123-0.59r-r1.ebuild,v 1.2 2002/04/27 11:57:51 seemant Exp $
+# $Id: mpg123-0.59r-r1.ebuild,v 1.3 2002/05/09 23:48:34 blauwers Exp $
S=${WORKDIR}/${P}
@@ -14,6 +14,7 @@ DEPEND="virtual/glibc"
src_unpack () {
unpack ${A}
cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-sparc.diff
cp Makefile Makefile.orig
sed -e "s:-O2 -m486:${CFLAGS}:" Makefile.orig > Makefile
}
@@ -24,14 +25,14 @@ src_compile() {
SYSTEM_ARCH=`echo $ARCH |\
sed -e s/[i]*.86/i386/ \
- -e s/sun4u/sparc64/ \
+ -e s/sun.*/sparc/ \
-e s/arm.*/arm/ \
-e s/sa110/arm/`
if [ -z "$SYSTEM_ARCH" ]
then
SYSTEM_ARCH=`uname -m |\
- sed -e s/[i]*.86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/`
+ sed -e s/[i]*.86/i386/ -e s/arm.*/arm/ -e s/sa110/arm/`
fi
case $SYSTEM_ARCH in
@@ -40,7 +41,9 @@ src_compile() {
i386)
MAKESTYLE="-i486";;
sparc64)
- ;;
+ MAKESTYLE="-sparc";;
+ sparc)
+ MAKESTYLE="-sparc";;
arm)
;;
esac