summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2003-12-14 22:58:04 +0000
committerSteve Arnold <nerdboy@gentoo.org>2003-12-14 22:58:04 +0000
commit5f902eed45bdb05f4f466c671b82529a22512140 (patch)
tree3954fb83c4323c3314e5eb1df8202a23c8a02082 /media-sound
parentnew ebuild for streaming audio server (diff)
downloadgentoo-2-5f902eed45bdb05f4f466c671b82529a22512140.tar.gz
gentoo-2-5f902eed45bdb05f4f466c671b82529a22512140.tar.bz2
gentoo-2-5f902eed45bdb05f4f466c671b82529a22512140.zip
new ebuild for streaming audio server
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/edna/ChangeLog10
-rw-r--r--media-sound/edna/Manifest4
-rw-r--r--media-sound/edna/edna-0.5.ebuild61
-rw-r--r--media-sound/edna/files/digest-edna-0.51
-rw-r--r--media-sound/edna/files/edna.gentoo25
-rw-r--r--media-sound/edna/metadata.xml11
6 files changed, 110 insertions, 2 deletions
diff --git a/media-sound/edna/ChangeLog b/media-sound/edna/ChangeLog
new file mode 100644
index 000000000000..9e2c6f7e1345
--- /dev/null
+++ b/media-sound/edna/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/edna
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/edna/ChangeLog,v 1.1 2003/12/14 22:57:58 nerdboy Exp $
+
+*edna-0.5 (14 Dec 2003)
+
+ 14 Dec 2003; <nerdboy@gentoo.org> edna-0.5.ebuild, metadata.xml,
+ files/edna.gentoo:
+ new ebuild for edna streaming audio server
+
diff --git a/media-sound/edna/Manifest b/media-sound/edna/Manifest
index 4d3f4d795dcf..a75c50a2918e 100644
--- a/media-sound/edna/Manifest
+++ b/media-sound/edna/Manifest
@@ -1,5 +1,5 @@
-MD5 0b483aba2ed17a04eacbd735d1b234af edna-0.5.ebuild 1423
+MD5 4caf954f9917d1f35b087afff3396725 edna-0.5.ebuild 1519
MD5 7b52e105c2857fc04035cd20183d8ee2 metadata.xml 324
-MD5 e5a7bb53ed116d5d4fa02e0101dddc7f ChangeLog 284
+MD5 8fe55309d926b79fc220501f0d0f4320 ChangeLog 374
MD5 1ec24bb2d64996afa8b8a32d8ba3c39e files/edna.gentoo 492
MD5 0afeb0ec9a434506f2b38f2e66dbb0e3 files/digest-edna-0.5 59
diff --git a/media-sound/edna/edna-0.5.ebuild b/media-sound/edna/edna-0.5.ebuild
new file mode 100644
index 000000000000..d9747b2ed593
--- /dev/null
+++ b/media-sound/edna/edna-0.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/edna/edna-0.5.ebuild,v 1.1 2003/12/14 22:57:58 nerdboy Exp $
+
+# This is Greg Stein's streaming audio server
+
+IUSE="python ednad"
+
+
+DESCRIPTION="Greg Stein's python streaming audio server for desktop or LAN use"
+HOMEPAGE="http://edna.sourceforge.net/"
+#SRC_URI="http://edna.sourceforge.net/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/edna/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-lang/python"
+
+RDEPEND="${DEPEND}"
+
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/edna-make.patch
+#}
+
+src_install() {
+
+ if [ "`use ednad`" ]; then
+ einfo "Installing in daemon mode"
+ insinto /etc/init.d
+ insopts -m 755
+ newins ${FILESDIR}/edna.gentoo edna
+ exeinto /usr/bin ; doexe daemon/ednad
+ fi
+
+ dodir /usr/bin /usr/lib/edna /usr/lib/edna/templates
+ exeinto /usr/bin ; newexe edna.py edna
+ exeinto /usr/lib/edna ; doexe ezt.py
+ exeinto /usr/lib/edna ; doexe MP3Info.py
+ insinto /usr/lib/edna/templates
+ insopts -m 644
+ doins templates/*
+
+ insinto /etc/edna
+ insopts -m 644
+ doins edna.conf
+ dosym templates /etc/edna/templates
+
+ dodoc COPYING README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn
+ einfo "Edit edna.conf to suite before starting edna and test it."
+ einfo "Emerge with USE="ednad" if you want to install in daemon"
+ einfo "mode. See edna.conf and the homepage for more info."
+ ewarn
+}
diff --git a/media-sound/edna/files/digest-edna-0.5 b/media-sound/edna/files/digest-edna-0.5
new file mode 100644
index 000000000000..98bcede95ebc
--- /dev/null
+++ b/media-sound/edna/files/digest-edna-0.5
@@ -0,0 +1 @@
+MD5 ec3d46b25fa582b78db7c32acf78da47 edna-0.5.tar.gz 85785
diff --git a/media-sound/edna/files/edna.gentoo b/media-sound/edna/files/edna.gentoo
new file mode 100644
index 000000000000..9199e00764b8
--- /dev/null
+++ b/media-sound/edna/files/edna.gentoo
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+#
+# Startup script for the edna mp3 mini server
+#
+# description: edna is a mini mp3 webserver
+# processname: python
+# pidfile: /var/run/ednad.pid
+# config:
+
+depend() {
+ need local
+}
+
+start() {
+ ebegin "Starting ednad mp3 server"
+ start-stop-daemon -b -m --quiet --start --exec /usr/bin/ednad \
+ --pidfile /var/run/ednad.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ednad"
+ start-stop-daemon -o --quiet --stop --pidfile /var/run/ednad.pid
+ eend $?
+}
diff --git a/media-sound/edna/metadata.xml b/media-sound/edna/metadata.xml
new file mode 100644
index 000000000000..133ef831146b
--- /dev/null
+++ b/media-sound/edna/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+</maintainer>
+<description>
+ Edna is Greg Stein's http streaming audio server for mp3 and ogg files.
+</description>
+</pkgmetadata>