summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-14 23:23:18 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-14 23:23:18 +0000
commit02699bedc336971df98a5c1488ff3782c108513d (patch)
treee8f00abb30d9a58225600b835e7bd8ecdfd21e78 /media-sound
parentRevbump with fix for bug #458892 (fix world-readable log file). (diff)
downloadgentoo-2-02699bedc336971df98a5c1488ff3782c108513d.tar.gz
gentoo-2-02699bedc336971df98a5c1488ff3782c108513d.tar.bz2
gentoo-2-02699bedc336971df98a5c1488ff3782c108513d.zip
Fix several dep issues by Nikoli <nikoli@lavabit.com> wrt bug #472140.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cantata/ChangeLog7
-rw-r--r--media-sound/cantata/cantata-1.0.3.ebuild66
-rw-r--r--media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch42
-rw-r--r--media-sound/cantata/files/cantata-1.0.3-system-qjson.patch35
-rw-r--r--media-sound/cantata/metadata.xml3
5 files changed, 127 insertions, 26 deletions
diff --git a/media-sound/cantata/ChangeLog b/media-sound/cantata/ChangeLog
index 4d248e59c956..743840d5d57a 100644
--- a/media-sound/cantata/ChangeLog
+++ b/media-sound/cantata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/cantata
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/ChangeLog,v 1.17 2013/06/02 06:12:25 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/ChangeLog,v 1.18 2013/06/14 23:23:18 johu Exp $
+
+ 14 Jun 2013; Johannes Huber <johu@gentoo.org>
+ +files/cantata-1.0.3-audiocd-automagic.patch,
+ +files/cantata-1.0.3-system-qjson.patch, cantata-1.0.3.ebuild, metadata.xml:
+ Fix several dep issues by Nikoli <nikoli@lavabit.com> wrt bug #472140.
*cantata-1.0.3 (02 Jun 2013)
diff --git a/media-sound/cantata/cantata-1.0.3.ebuild b/media-sound/cantata/cantata-1.0.3.ebuild
index e8b7fb323bc9..e93495fbb940 100644
--- a/media-sound/cantata/cantata-1.0.3.ebuild
+++ b/media-sound/cantata/cantata-1.0.3.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/cantata-1.0.3.ebuild,v 1.1 2013/06/02 06:12:25 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/cantata-1.0.3.ebuild,v 1.2 2013/06/14 23:23:18 johu Exp $
EAPI=5
KDE_REQUIRED="optional"
inherit kde4-base
DESCRIPTION="A featureful and configurable Qt4 client for the music player daemon (MPD)"
-HOMEPAGE="http://kde-apps.org/content/show.php?content=147733"
+HOMEPAGE="https://code.google.com/p/cantata/"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="4"
KEYWORDS="~amd64 ~x86"
-IUSE="kde mtp phonon qt5 replaygain webkit"
-REQUIRED_USE="mtp? ( kde ) qt5? ( !kde !phonon )"
+IUSE="cddb cdparanoia kde lame mtp musicbrainz online-services phonon qt5 replaygain taglib"
+REQUIRED_USE="
+ cddb? ( cdparanoia taglib )
+ cdparanoia? ( || ( cddb musicbrainz ) )
+ lame? ( cdparanoia taglib )
+ mtp? ( taglib )
+ musicbrainz? ( cdparanoia taglib )
+ online-services? ( taglib )
+ qt5? ( !kde !phonon )
+ replaygain? ( taglib )
+"
DEPEND="
- kde? (
- media-libs/taglib[asf,mp4]
- media-libs/taglib-extras
- mtp? ( media-libs/libmtp )
- )
+ lame? ( media-sound/lame )
+ mtp? ( media-libs/libmtp )
phonon? ( || ( media-libs/phonon dev-qt/qtphonon:4 ) )
qt5? (
dev-qt/qtconcurrent:5
@@ -36,40 +42,52 @@ DEPEND="
)
replaygain? (
media-libs/speex
- media-libs/taglib[asf,mp4]
- media-libs/taglib-extras
media-sound/mpg123
virtual/ffmpeg
)
- webkit? ( dev-qt/qtwebkit:4 )
+ taglib? (
+ media-libs/taglib[asf,mp4]
+ media-libs/taglib-extras
+ !kde? ( sys-fs/udisks:2 )
+ )
+ dev-libs/qjson
+ sys-libs/zlib
"
RDEPEND="${DEPEND}
$(add_kdebase_dep oxygen-icons)
"
+PATCHES=(
+ "${FILESDIR}/${P}-audiocd-automagic.patch"
+ "${FILESDIR}/${P}-system-qjson.patch"
+)
+
src_prepare() {
+ kde4-base_src_prepare
+
+ rm -rf 3rdparty/qjson/
+
# make desktop file pass validation
- sed -e 's/MPD/MPD;/' -i ${PN}.desktop || die 'sed failed'
+ sed -e 's/MPD/MPD;/' -i ${PN}.desktop || die
}
src_configure() {
local mycmakeargs=(
+ $(cmake-utils_use_enable cddb)
+ $(cmake-utils_use_enable cdparanoia)
$(cmake-utils_use_enable kde)
+ $(cmake-utils_use_enable lame)
+ $(cmake-utils_use_enable mtp)
+ $(cmake-utils_use_enable musicbrainz)
+ $(cmake-utils_use_enable online-services ONLINE_SERVICES)
$(cmake-utils_use_enable phonon)
+ $(cmake-utils_use_enable qt5)
$(cmake-utils_use_enable replaygain FFMPEG)
$(cmake-utils_use_enable replaygain MPG123)
$(cmake-utils_use_enable replaygain SPEEXDSP)
- $(cmake-utils_use_enable mtp)
+ $(cmake-utils_use_enable taglib)
+ $(cmake-utils_use_enable taglib TAGLIB_EXTRAS)
+ -DENABLE_UDISKS2=ON
)
-
- # kde fails to build without taglib
- # taglib is required to enable replaygain
- if use kde || use replaygain; then
- mycmakeargs+=(
- -DENABLE_TAGLIB=ON
- -DENABLE_TAGLIB_EXTRAS=ON
- )
- fi
-
kde4-base_src_configure
}
diff --git a/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch b/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
new file mode 100644
index 000000000000..311aac1a3b74
--- /dev/null
+++ b/media-sound/cantata/files/cantata-1.0.3-audiocd-automagic.patch
@@ -0,0 +1,42 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 2749)
++++ CMakeLists.txt (revision 2750)
+@@ -33,6 +33,10 @@
+ OPTION(ENABLE_UDISKS2 "Build UDisks2 backend, and NOT UDisks, for Qt builds" OFF)
+ OPTION(ENABLE_OVERLAYSCROLLBARS "Enable support for overlay style scrollbars when using QGtkStyle (Linux only)" OFF)
+ OPTION(ENABLE_ONLINE_SERVICES "Enable support for online services (Jamendo and Magantune)" ON)
++OPTION(ENABLE_CDPARANOIA "Enable CDParanoia libraries (required for AudioCD support)" ON)
++OPTION(ENABLE_CDDB "Enable CDDB libraries (either this or MusicBrianz required for AudioCD support)" ON)
++OPTION(ENABLE_MUSICBRAINZ "Enable MusicBrianz libraries (either this or CDDB required for AudioCD support)" ON)
++OPTION(ENABLE_LAME "Enable LAME libraries (required for AudioCD playback support)" ON)
+
+ if (ENABLE_QT5)
+ set(ENABLE_PHONON FALSE)
+@@ -142,12 +146,20 @@
+ SET( CANTATA_UIS ${CANTATA_UIS} online/onlineservicespage.ui)
+ endif (ENABLE_ONLINE_SERVICES)
+
+-find_package( Cdparanoia )
+-if (CDPARANOIA_FOUND)
+- find_package( CDDB )
+- find_package( MusicBrainz5 )
+- find_package( Lame )
+-endif (CDPARANOIA_FOUND)
++if (ENABLE_CDPARANOIA)
++ find_package(Cdparanoia)
++ if (CDPARANOIA_FOUND)
++ if (ENABLE_CDDB)
++ find_package(CDDB)
++ endif (ENABLE_CDDB)
++ if (ENABLE_MUSICBRAINZ)
++ find_package(MusicBrainz5)
++ endif (ENABLE_MUSICBRAINZ)
++ if (ENABLE_LAME)
++ find_package(Lame)
++ endif (ENABLE_LAME)
++ endif (CDPARANOIA_FOUND)
++endif (ENABLE_CDPARANOIA)
+
+ if (ENABLE_TAGLIB)
+ set(TAGLIB_MIN_VERSION "1.6")
diff --git a/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch b/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch
new file mode 100644
index 000000000000..3bae049af2e5
--- /dev/null
+++ b/media-sound/cantata/files/cantata-1.0.3-system-qjson.patch
@@ -0,0 +1,35 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 2794)
++++ CMakeLists.txt (revision 2795)
+@@ -166,6 +166,10 @@
+ find_package(Taglib)
+ endif (ENABLE_TAGLIB)
+
++if (NOT ENABLE_QT5 AND NOT WIN32)
++ find_package( QJSON )
++endif (NOT ENABLE_QT5 AND NOT WIN32)
++
+ if (ENABLE_OVERLAYSCROLLBARS)
+ add_definitions(-DENABLE_OVERLAYSCROLLBARS)
+ endif (ENABLE_OVERLAYSCROLLBARS)
+@@ -495,9 +499,17 @@
+ endif (NOT WIN32)
+
+ add_subdirectory(3rdparty/qtiocompressor)
+-add_subdirectory(3rdparty/qjson)
+-TARGET_LINK_LIBRARIES(cantata qtiocompressor qjson)
+
++if (QJSON_FOUND)
++ include_directories(${QJSON_INCLUDE_DIR})
++ TARGET_LINK_LIBRARIES(cantata ${QJSON_LIBRARIES})
++else (QJSON_FOUND)
++ add_subdirectory(3rdparty/qjson)
++ TARGET_LINK_LIBRARIES(cantata qjson)
++endif (QJSON_FOUND)
++
++TARGET_LINK_LIBRARIES(cantata qtiocompressor)
++
+ ADD_SUBDIRECTORY( icons )
+
+ target_link_libraries(cantata support sha2 ${QTLIBS} ${ZLIB_LIBRARIES})
diff --git a/media-sound/cantata/metadata.xml b/media-sound/cantata/metadata.xml
index a7742c06462f..696f16127be7 100644
--- a/media-sound/cantata/metadata.xml
+++ b/media-sound/cantata/metadata.xml
@@ -4,7 +4,8 @@
<herd>kde</herd>
<herd>qt</herd>
<use>
- <flag name="phonon">Enable support for Phonon</flag>
+ <flag name="online-services">Enable support for online services (Jamendo and Magantune)</flag>
+ <flag name="phonon">Enable support for Phonon</flag>
<flag name="replaygain">Enable ReplayGain support, for relative volume adjustments.</flag>
</use>
</pkgmetadata>