summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-05 15:40:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-05 15:40:11 +0000
commit7abe7ab883faaa41d6afca7708929a4e88e7743b (patch)
tree049d346e17b8f6b523bce4f854eac920d3649d0b /media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild
parentx86 stable wrt bug #311741 (diff)
downloadgentoo-2-7abe7ab883faaa41d6afca7708929a4e88e7743b.tar.gz
gentoo-2-7abe7ab883faaa41d6afca7708929a4e88e7743b.tar.bz2
gentoo-2-7abe7ab883faaa41d6afca7708929a4e88e7743b.zip
Version bump wrt #312917 by William Swartzendruber.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild')
-rw-r--r--media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild b/media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild
new file mode 100644
index 000000000000..51e2226ca213
--- /dev/null
+++ b/media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbis-tools/vorbis-tools-1.4.0.ebuild,v 1.1 2010/04/05 15:40:11 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="tools for using the Ogg Vorbis sound file format"
+HOMEPAGE="http://www.vorbis.com"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac kate nls +ogg123 speex"
+
+RDEPEND=">=media-libs/libvorbis-1.3.0
+ flac? ( media-libs/flac )
+ kate? ( media-libs/libkate )
+ ogg123? ( >=media-libs/libao-1.0.0
+ net-misc/curl )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable ogg123) \
+ $(use_with flac) \
+ $(use_with speex) \
+ $(use_with kate)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS CHANGES README
+}