summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2012-06-30 16:03:20 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2012-06-30 16:03:20 +0000
commitcc037dcfb6911673f670c390b608272e9da25699 (patch)
tree9273c2adf6612259130c35a689ba2f57c985c190 /media-sound/vdramgw
parentversion bump (diff)
downloadgentoo-2-cc037dcfb6911673f670c390b608272e9da25699.tar.gz
gentoo-2-cc037dcfb6911673f670c390b608272e9da25699.tar.bz2
gentoo-2-cc037dcfb6911673f670c390b608272e9da25699.zip
gcc-4.7 compile fixed, bug 424101; eapi=4; fixed c++ includes; minor fixes in ebuild
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-sound/vdramgw')
-rw-r--r--media-sound/vdramgw/ChangeLog9
-rw-r--r--media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch6
-rw-r--r--media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff92
-rw-r--r--media-sound/vdramgw/vdramgw-0.0.2.ebuild18
4 files changed, 113 insertions, 12 deletions
diff --git a/media-sound/vdramgw/ChangeLog b/media-sound/vdramgw/ChangeLog
index 3d57dd32898f..afd9682e36b9 100644
--- a/media-sound/vdramgw/ChangeLog
+++ b/media-sound/vdramgw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/vdramgw
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/ChangeLog,v 1.4 2010/08/13 21:31:17 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/ChangeLog,v 1.5 2012/06/30 16:03:20 hd_brummy Exp $
+
+ 30 Jun 2012; Joerg Bornkessel <hd_brummy@gentoo.org> vdramgw-0.0.2.ebuild,
+ files/vdramgw-0.0.2-gcc43.patch, +files/vdramgw-0.0.2_gcc-4.7.diff:
+ gcc-4.7 compile fixed, bug 424101; eapi=4; fixed c++ includes; minor fixes in
+ ebuild
13 Aug 2010; Markos Chandras <hwoarang@gentoo.org> vdramgw-0.0.2.ebuild:
Respect CXX,CXXFLAGS,LDFLAGS. Bug #332543. Thanks to Diego E. 'Flameeyes'
diff --git a/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch b/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch
index ff504c090e53..8c3ac7452aae 100644
--- a/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch
+++ b/media-sound/vdramgw/files/vdramgw-0.0.2-gcc43.patch
@@ -5,7 +5,7 @@ diff -ur amarok-0.0.2.orig/Sockets.cpp amarok-0.0.2/Sockets.cpp
#include "Sockets.h"
-+#include <string.h>
++#include <cstring>
#include <sstream>
#ifndef WIN32
@@ -16,7 +16,7 @@ diff -ur amarok-0.0.2.orig/vdramgw/Sockets.cpp amarok-0.0.2/vdramgw/Sockets.cpp
#include "Sockets.h"
-+#include <string.h>
++#include <cstring>
#include <sstream>
#ifndef WIN32
@@ -28,7 +28,7 @@ diff -ur amarok-0.0.2.orig/vdramgw/vdramgw.cpp amarok-0.0.2/vdramgw/vdramgw.cpp
#endif
-
-+#include <string.h>
++#include <cstring>
#include <unistd.h>
#include <getopt.h>
#include <iostream>
diff --git a/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff b/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff
new file mode 100644
index 000000000000..c5182cfd33d6
--- /dev/null
+++ b/media-sound/vdramgw/files/vdramgw-0.0.2_gcc-4.7.diff
@@ -0,0 +1,92 @@
+gcc-4.7 compile fix
+https://bugs.gentoo.org/show_bug.cgi?id=424101
+
+signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2012/30/06)
+diff -Naur amarok-0.0.2.orig/Sockets.h amarok-0.0.2/Sockets.h
+--- amarok-0.0.2.orig/Sockets.h 2012-06-30 17:40:27.000000000 +0200
++++ amarok-0.0.2/Sockets.h 2012-06-30 17:43:21.000000000 +0200
+@@ -182,8 +182,8 @@
+ {
+ if (this->gptr() == NULL)
+ {
+- setg(s, s + n, s + n);
+- setp(s, s + n);
++ this->setg(s, s + n, s + n);
++ this->setp(s, s + n);
+ inbuf_ = s;
+ outbuf_ = s;
+ bufsize_ = n;
+@@ -215,9 +215,9 @@
+ {
+ _flush();
+ }
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ if (c != traits::eof())
+- sputc(traits::to_char_type(c));
++ this->sputc(traits::to_char_type(c));
+ return 0;
+ }
+
+@@ -225,7 +225,7 @@
+ {
+ // just flush the put area
+ _flush();
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ return 0;
+ }
+
+@@ -256,7 +256,7 @@
+ return traits::eof();
+
+ size_t totalbytes = readn + remained_;
+- setg(inbuf_, inbuf_,
++ this->setg(inbuf_, inbuf_,
+ inbuf_ + totalbytes / sizeof(char_type));
+
+ remained_ = totalbytes % sizeof(char_type);
+diff -Naur amarok-0.0.2.orig/vdramgw/Sockets.h amarok-0.0.2/vdramgw/Sockets.h
+--- amarok-0.0.2.orig/vdramgw/Sockets.h 2012-06-30 17:40:27.000000000 +0200
++++ amarok-0.0.2/vdramgw/Sockets.h 2012-06-30 17:41:52.000000000 +0200
+@@ -182,8 +182,8 @@
+ {
+ if (this->gptr() == NULL)
+ {
+- setg(s, s + n, s + n);
+- setp(s, s + n);
++ this->setg(s, s + n, s + n);
++ this->setp(s, s + n);
+ inbuf_ = s;
+ outbuf_ = s;
+ bufsize_ = n;
+@@ -215,9 +215,9 @@
+ {
+ _flush();
+ }
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ if (c != traits::eof())
+- sputc(traits::to_char_type(c));
++ this->sputc(traits::to_char_type(c));
+ return 0;
+ }
+
+@@ -225,7 +225,7 @@
+ {
+ // just flush the put area
+ _flush();
+- setp(outbuf_, outbuf_ + bufsize_);
++ this->setp(outbuf_, outbuf_ + bufsize_);
+ return 0;
+ }
+
+@@ -256,7 +256,7 @@
+ return traits::eof();
+
+ size_t totalbytes = readn + remained_;
+- setg(inbuf_, inbuf_,
++ this->setg(inbuf_, inbuf_,
+ inbuf_ + totalbytes / sizeof(char_type));
+
+ remained_ = totalbytes % sizeof(char_type);
diff --git a/media-sound/vdramgw/vdramgw-0.0.2.ebuild b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
index 16f7c4a83290..6a73df242dc0 100644
--- a/media-sound/vdramgw/vdramgw-0.0.2.ebuild
+++ b/media-sound/vdramgw/vdramgw-0.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/vdramgw-0.0.2.ebuild,v 1.5 2010/08/13 21:31:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vdramgw/vdramgw-0.0.2.ebuild,v 1.6 2012/06/30 16:03:20 hd_brummy Exp $
+
+EAPI="4"
inherit eutils toolchain-funcs
@@ -16,18 +18,20 @@ KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND=""
-RDEPEND=""
+RDEPEND="${DEPEND}"
+RDEPEND="media-sound/amarok"
S="${WORKDIR}/${MY_P#vdr-}/${PN}"
-RDEPEND="media-sound/amarok"
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc43.patch
+src_prepare() {
# Respect CC,CXXFLAGS, LDFLAGS
sed -i -e "/^CXX /s:?=.*:= $(tc-getCXX):" \
-e "/^CXXFLAGS/s:?=.*:= ${CFLAGS}:" \
-e "s:\$(CXXFLAGS):& \$(LDFLAGS) :" "${S}"/Makefile
+
+ cd "${WORKDIR}/${MY_P#vdr-}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}/${P}_gcc-4.7.diff"
}
src_install() {