summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-12-03 15:26:50 +0000
committerAron Griffis <agriffis@gentoo.org>2002-12-03 15:26:50 +0000
commit86e2a04ade34c660274025e5bd25d8fdfc8c4604 (patch)
tree479c0d67886bf65fea9ebbab66e3fdfbf7784c94 /media-sound/timidity-eawpatches
parentremove stray instances of set_enable_final (diff)
downloadgentoo-2-86e2a04ade34c660274025e5bd25d8fdfc8c4604.tar.gz
gentoo-2-86e2a04ade34c660274025e5bd25d8fdfc8c4604.tar.bz2
gentoo-2-86e2a04ade34c660274025e5bd25d8fdfc8c4604.zip
Fix bug #8753: timidity-eawpatches installation probs
Diffstat (limited to 'media-sound/timidity-eawpatches')
-rw-r--r--media-sound/timidity-eawpatches/ChangeLog9
-rw-r--r--media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r11
-rw-r--r--media-sound/timidity-eawpatches/timidity-eawpatches-12-r1.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/media-sound/timidity-eawpatches/ChangeLog b/media-sound/timidity-eawpatches/ChangeLog
index d8cff24e8f88..0b2bec51c037 100644
--- a/media-sound/timidity-eawpatches/ChangeLog
+++ b/media-sound/timidity-eawpatches/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/timidity-eawpatches
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/ChangeLog,v 1.1 2002/05/19 19:36:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/ChangeLog,v 1.2 2002/12/03 15:26:50 agriffis Exp $
+
+*timidity-eawpatches-12-r1 (03 Dec 2002)
+
+ 03 Dec 2002; Aron Griffis <agriffis@gentoo.org> timidity-eawpatches-12-r1:
+
+ Fix some installation issues with hints from Chris Moeller
+ <kode54@earthlink.net>. Fixes BUG #8753
*timidity-eawpatches-12 (19 May 2002)
diff --git a/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r1 b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r1
new file mode 100644
index 000000000000..e21b59465f77
--- /dev/null
+++ b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r1
@@ -0,0 +1 @@
+MD5 1f49190da4b1b4bdf999e0351edda8f2 eawpats12_full.rar 24444187
diff --git a/media-sound/timidity-eawpatches/timidity-eawpatches-12-r1.ebuild b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r1.ebuild
new file mode 100644
index 000000000000..6825d36c6372
--- /dev/null
+++ b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/timidity-eawpatches-12-r1.ebuild,v 1.1 2002/12/03 15:26:50 agriffis Exp $
+
+S=${WORKDIR}/eawpatches
+DESCRIPTION="Eric Welsh's GUS patches for TiMidity"
+SRC_URI="http://www.stardate.bc.ca/eawpatches/eawpats${PV}_full.rar"
+HOMEPAGE="http://www.stardate.bc.ca/eawpatches/html/default.htm"
+
+DEPEND="media-sound/timidity++
+ app-arch/unrar"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+src_unpack() {
+ mkdir eawpatches
+ cd eawpatches
+ unrar x "${DISTDIR}/${A}" || die "error unpacking ${DISTDIR}/${A}"
+
+ # Patch the default configuration so the patches can be found
+ patch -p0 < "${FILESDIR}/${PN}-12-gentoo.diff"
+}
+
+src_install () {
+ local instdir=/usr/share/timidity
+
+ # Install base timidity configuration
+ insinto ${instdir}
+ doins timidity.cfg
+ rm timidity.cfg
+
+ # Install base eawpatches
+ insinto ${instdir}/eawpatches
+ doins *.cfg *.pat
+ rm *.cfg *.pat
+
+ # Install patches from subdirectories
+ for d in `find . -type f -name \*.pat | sed 's,/[^/]*$,,' | sort -u`; do
+ insinto ${instdir}/eawpatches/${d}
+ doins ${d}/*.pat
+ done
+
+ # Install documentation, including subdirs
+ find . -name \*.txt | xargs dodoc
+}