summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-09-18 18:22:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-09-18 18:22:05 +0000
commita95b2cf4ff4f23e53b675eac3317477caf3b9448 (patch)
tree8f0736352c23d9e4bbc96f58f341cd87a640ac98 /media-sound/sox
parentFix broken Manifest for josm-plugins-20070907.ebuild. (diff)
downloadgentoo-2-a95b2cf4ff4f23e53b675eac3317477caf3b9448.tar.gz
gentoo-2-a95b2cf4ff4f23e53b675eac3317477caf3b9448.tar.bz2
gentoo-2-a95b2cf4ff4f23e53b675eac3317477caf3b9448.zip
disable support for external gsm lib for now until it installs correct libs (pic), bug #192736
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/ChangeLog7
-rw-r--r--media-sound/sox/files/sox-14.0.0-noexternalgsm.patch15
-rw-r--r--media-sound/sox/sox-14.0.0.ebuild12
3 files changed, 32 insertions, 2 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 17992cddc486..d590cc872219 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.66 2007/09/11 21:05:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.67 2007/09/18 18:22:04 aballier Exp $
+
+ 18 Sep 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/sox-14.0.0-noexternalgsm.patch, sox-14.0.0.ebuild:
+ disable support for external gsm lib for now until it installs correct libs
+ (pic), bug #192736
*sox-14.0.0 (11 Sep 2007)
diff --git a/media-sound/sox/files/sox-14.0.0-noexternalgsm.patch b/media-sound/sox/files/sox-14.0.0-noexternalgsm.patch
new file mode 100644
index 000000000000..88091a48153b
--- /dev/null
+++ b/media-sound/sox/files/sox-14.0.0-noexternalgsm.patch
@@ -0,0 +1,15 @@
+Index: sox-14.0.0/configure.ac
+===================================================================
+--- sox-14.0.0.orig/configure.ac
++++ sox-14.0.0/configure.ac
+@@ -186,8 +186,8 @@ fi
+ AM_CONDITIONAL(HAVE_SUN_AUDIO, test x$enable_sun_audio = xyes)
+
+ dnl Check for libgsm
+-AC_CHECK_HEADERS(gsm/gsm.h, found_libgsm=yes,
+- [AC_CHECK_HEADERS(gsm.h, found_libgsm=yes)])
++AC_CHECK_HEADERS(gsm/gsm.h, found_libgsm=blah,
++ [AC_CHECK_HEADERS(gsm.h, found_libgsm=blah)])
+ if test "$found_libgsm" = yes; then
+ AC_CHECK_LIB(gsm, gsm_create, GSM_LIBS="$GSM_LIBS -lgsm")
+ AC_DEFINE(EXTERNAL_GSM, 1, [Define if you are using an external GSM library])
diff --git a/media-sound/sox/sox-14.0.0.ebuild b/media-sound/sox/sox-14.0.0.ebuild
index 943c56b8ba81..0fd3570b1bbf 100644
--- a/media-sound/sox/sox-14.0.0.ebuild
+++ b/media-sound/sox/sox-14.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.0.0.ebuild,v 1.1 2007/09/11 21:05:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.0.0.ebuild,v 1.2 2007/09/18 18:22:04 aballier Exp $
inherit flag-o-matic eutils autotools
@@ -27,6 +27,16 @@ DEPEND="alsa? ( media-libs/alsa-lib )
# amrnb? ( media-libs/amrnb )
# amrwb? ( media-libs/amrwb )
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Disable external gsm lib support until it installs properly the lib
+ # Bug #192736
+ epatch "${FILESDIR}/${P}-noexternalgsm.patch"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
src_compile () {
# Fixes wav segfaults. See Bug #35745.
append-flags -fsigned-char