summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-15 21:02:22 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-15 21:02:22 +0000
commitbf51ae472be24b022f70d359b7bfcf7d7d793c54 (patch)
treed821a7f6012586e5f350dced78a608800e2c114e /media-sound/soundtracker
parentamd64 stable, bug #215149 (diff)
downloadgentoo-2-bf51ae472be24b022f70d359b7bfcf7d7d793c54.tar.gz
gentoo-2-bf51ae472be24b022f70d359b7bfcf7d7d793c54.tar.bz2
gentoo-2-bf51ae472be24b022f70d359b7bfcf7d7d793c54.zip
pass --disable-alsa since there is no support for recent alsa wrt #196636.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-sound/soundtracker')
-rw-r--r--media-sound/soundtracker/ChangeLog5
-rw-r--r--media-sound/soundtracker/soundtracker-0.6.8.ebuild50
2 files changed, 23 insertions, 32 deletions
diff --git a/media-sound/soundtracker/ChangeLog b/media-sound/soundtracker/ChangeLog
index 8e1608a8328e..64fa07be803a 100644
--- a/media-sound/soundtracker/ChangeLog
+++ b/media-sound/soundtracker/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/soundtracker
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/ChangeLog,v 1.27 2008/02/29 20:07:24 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/ChangeLog,v 1.28 2008/05/15 21:02:22 drac Exp $
+
+ 15 May 2008; Samuli Suominen <drac@gentoo.org> soundtracker-0.6.8.ebuild:
+ pass --disable-alsa since there is no support for recent alsa wrt #196636.
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> soundtracker-0.6.8.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/media-sound/soundtracker/soundtracker-0.6.8.ebuild b/media-sound/soundtracker/soundtracker-0.6.8.ebuild
index 08f1c6f303bf..a229129e9457 100644
--- a/media-sound/soundtracker/soundtracker-0.6.8.ebuild
+++ b/media-sound/soundtracker/soundtracker-0.6.8.ebuild
@@ -1,43 +1,35 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.8.ebuild,v 1.6 2008/02/29 20:07:24 carlo Exp $
-
-IUSE="alsa esd jack nls oss sdl"
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.8.ebuild,v 1.7 2008/05/15 21:02:22 drac Exp $
inherit eutils
-S=${WORKDIR}/${P/_/-}
-
DESCRIPTION="SoundTracker is a music tracking tool for UNIX/X11 (MOD tracker)"
SRC_URI="http://www.soundtracker.org/dl/v0.6/${P/_/-}.tar.gz"
HOMEPAGE="http://www.soundtracker.org"
-RDEPEND="sys-libs/zlib
- =x11-libs/gtk+-1.2*
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc sparc x86"
+IUSE="esd jack nls oss sdl"
+
+RDEPEND="=x11-libs/gtk+-1.2*
>=media-libs/audiofile-0.2.1
media-libs/libsndfile
- alsa? ( media-libs/alsa-lib )
esd? ( media-sound/esound )
jack? ( media-sound/jack-audio-connection-kit )
- sdl? ( >=media-libs/libsdl-1.2.0 )
+ sdl? ( >=media-libs/libsdl-1.2 )
nls? ( virtual/libintl )"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
- dev-util/pkgconfig
- app-arch/bzip2
- app-arch/gzip
- app-arch/unzip"
+ dev-util/pkgconfig"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha amd64 ~ppc sparc x86"
+S=${WORKDIR}/${P/_/-}
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.6.7-execstack.patch"
+ epatch "${FILESDIR}"/${PN}-0.6.7-execstack.patch
}
src_compile() {
@@ -46,28 +38,24 @@ src_compile() {
use oss || myconf="--disable-oss"
use esd || myconf="${myconf} --disable-esd"
use nls || myconf="${myconf} --disable-nls"
- use alsa || myconf="${myconf} --disable-alsa"
myconf="${myconf} --disable-gnome"
use x86 && myconf="${myconf} --enable-asm"
use jack || myconf="${myconf} --disable-jack"
use sdl || myconf="${myconf} --disable-sdl"
- econf ${myconf} || die "configure failed"
- emake || die "make failed"
+ # no support for recent alsa wrt 196636
+ econf --disable-alsa ${myconf} || die "econf failed."
+ emake || die "emake failed."
}
src_install () {
- einstall || die "make install failed"
- #borks make DESTDIR=${D} install || die "make install failed"
+ einstall || die "einstall failed."
- # strip suid from binary
- chmod -s ${D}/usr/bin/soundtracker
+ fperms -s /usr/bin/${PN}
- # documentation
- dodoc AUTHORS ChangeLog* FAQ NEWS README TODO
- dodoc doc/*.txt
+ dodoc AUTHORS ChangeLog* FAQ NEWS README TODO doc/*.txt
dohtml -r doc
- doicon soundtracker_splash.png
- make_desktop_entry soundtracker SoundTracker soundtracker_splash
+ doicon ${PN}_splash.png
+ make_desktop_entry ${PN} SoundTracker ${PN}_splash
}