summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-05 03:50:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-05 03:50:37 +0000
commitf9c8189032b8959f292dac3d4ef27683a05c806b (patch)
treec7c8f1c0fe360b880fa21e1fe491b43b3cbf45b4 /media-sound/rexima
parentbalance parens (Manifest recommit) (diff)
downloadgentoo-2-f9c8189032b8959f292dac3d4ef27683a05c806b.tar.gz
gentoo-2-f9c8189032b8959f292dac3d4ef27683a05c806b.tar.bz2
gentoo-2-f9c8189032b8959f292dac3d4ef27683a05c806b.zip
removed incorrect S (bug #46788); use sed -i; IUSE; error messages; tidy
Diffstat (limited to 'media-sound/rexima')
-rw-r--r--media-sound/rexima/ChangeLog5
-rw-r--r--media-sound/rexima/rexima-1.4.ebuild32
2 files changed, 18 insertions, 19 deletions
diff --git a/media-sound/rexima/ChangeLog b/media-sound/rexima/ChangeLog
index cce242527e24..2404651b7011 100644
--- a/media-sound/rexima/ChangeLog
+++ b/media-sound/rexima/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/rexima
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/ChangeLog,v 1.3 2004/04/01 07:53:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/ChangeLog,v 1.4 2004/04/05 03:50:37 mr_bones_ Exp $
+
+ 04 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> rexima-1.4.ebuild:
+ removed incorrect S (bug #46788); use sed -i; IUSE; error messages; tidy
31 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> rexima-1.4.ebuild:
Removed explicot S=. Stable x86.
diff --git a/media-sound/rexima/rexima-1.4.ebuild b/media-sound/rexima/rexima-1.4.ebuild
index f7047ca37aeb..e585b181056a 100644
--- a/media-sound/rexima/rexima-1.4.ebuild
+++ b/media-sound/rexima/rexima-1.4.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/rexima-1.4.ebuild,v 1.4 2004/04/01 07:53:01 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/rexima-1.4.ebuild,v 1.5 2004/04/05 03:50:37 mr_bones_ Exp $
-S=${WORKDIR}/${PN}
DESCRIPTION="A curses-based interactive mixer which can also be used from the command-line."
HOMEPAGE="http://rus.members.beeb.net/rexima.html"
SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/mixers/${PN}-${PV}.tar.gz"
-DEPEND="virtual/glibc
- sys-libs/ncurses"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_compile() {
- cd ${S}
- mv Makefile Makefile.orig
- cat Makefile.orig | sed "s%/usr/local%/usr%" > Makefile
- emake || die
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install () {
- cd ${S}
-
make \
- PREFIX=${D}/usr \
- BINDIR=${D}/usr/bin \
- MANDIR=${D}/usr/share/man \
- install || die
-
- dodoc COPYING NEWS README
+ PREFIX="${D}/usr" \
+ BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man" \
+ install || die "make install failed"
+ dodoc NEWS README
}