summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-01-09 20:46:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-01-09 20:46:33 +0000
commit194e8e1741210c820edcc74f58475f299379aed0 (patch)
tree5ca54245306c826e37c8a3fc77fc8196d4a30477 /media-sound/quodlibet
parentRemoved check for dev-python/pygtk gnome USE-flag. (diff)
downloadgentoo-2-194e8e1741210c820edcc74f58475f299379aed0.tar.gz
gentoo-2-194e8e1741210c820edcc74f58475f299379aed0.tar.bz2
gentoo-2-194e8e1741210c820edcc74f58475f299379aed0.zip
Adding a patch to catch exception when hal is not running, bug #161139
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'media-sound/quodlibet')
-rw-r--r--media-sound/quodlibet/ChangeLog8
-rw-r--r--media-sound/quodlibet/files/digest-quodlibet-0.24-r13
-rw-r--r--media-sound/quodlibet/files/quodlibet-0.24-hal.patch24
-rw-r--r--media-sound/quodlibet/quodlibet-0.24-r1.ebuild126
4 files changed, 160 insertions, 1 deletions
diff --git a/media-sound/quodlibet/ChangeLog b/media-sound/quodlibet/ChangeLog
index f7b615e1a324..1fc49913f2b0 100644
--- a/media-sound/quodlibet/ChangeLog
+++ b/media-sound/quodlibet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/quodlibet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/ChangeLog,v 1.46 2007/01/06 20:17:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/ChangeLog,v 1.47 2007/01/09 20:46:33 aballier Exp $
+
+*quodlibet-0.24-r1 (09 Jan 2007)
+
+ 09 Jan 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/quodlibet-0.24-hal.patch, +quodlibet-0.24-r1.ebuild:
+ Adding a patch to catch exception when hal is not running, bug #161139
*quodlibet-0.24 (06 Jan 2007)
diff --git a/media-sound/quodlibet/files/digest-quodlibet-0.24-r1 b/media-sound/quodlibet/files/digest-quodlibet-0.24-r1
new file mode 100644
index 000000000000..c3ff4b385dc2
--- /dev/null
+++ b/media-sound/quodlibet/files/digest-quodlibet-0.24-r1
@@ -0,0 +1,3 @@
+MD5 39718994ee234d0c442d9db330d7445a quodlibet-0.24.tar.gz 615554
+RMD160 b4fec7495b081abc92faf74a746c4f43c66f1ead quodlibet-0.24.tar.gz 615554
+SHA256 758d726fa57b177d574dc01141609df3415287611db073415230f1ac4520fd5e quodlibet-0.24.tar.gz 615554
diff --git a/media-sound/quodlibet/files/quodlibet-0.24-hal.patch b/media-sound/quodlibet/files/quodlibet-0.24-hal.patch
new file mode 100644
index 000000000000..1c373cb97912
--- /dev/null
+++ b/media-sound/quodlibet/files/quodlibet-0.24-hal.patch
@@ -0,0 +1,24 @@
+--- browsers/media.py 2006-10-09 01:34:00.000000000 +0200
++++ browsers/media.py.new 2007-01-09 21:32:43.000000000 +0100
+@@ -143,12 +143,15 @@
+
+ @classmethod
+ def init(klass, library):
+- devices._hal.connect_to_signal(
+- 'DeviceAdded', klass.__hal_device_added)
+- devices._hal.connect_to_signal(
+- 'DeviceRemoved', klass.__hal_device_removed)
+- for udi in devices.discover():
+- klass.__hal_device_added(udi)
++ try:
++ devices._hal.connect_to_signal(
++ 'DeviceAdded', klass.__hal_device_added)
++ devices._hal.connect_to_signal(
++ 'DeviceRemoved', klass.__hal_device_removed)
++ for udi in devices.discover():
++ klass.__hal_device_added(udi)
++ except:
++ print "Hal not found"
+
+ @classmethod
+ def devices(klass):
diff --git a/media-sound/quodlibet/quodlibet-0.24-r1.ebuild b/media-sound/quodlibet/quodlibet-0.24-r1.ebuild
new file mode 100644
index 000000000000..7a572fad6d13
--- /dev/null
+++ b/media-sound/quodlibet/quodlibet-0.24-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/quodlibet/quodlibet-0.24-r1.ebuild,v 1.1 2007/01/09 20:46:33 aballier Exp $
+
+inherit eutils python
+
+DESCRIPTION="Quod Libet is a GTK+-based audio player written in Python."
+HOMEPAGE="http://www.sacredchao.net/quodlibet/"
+SRC_URI="http://www.sacredchao.net/~piman/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="aac alsa dbus esd flac gnome hal mad mmkeys musepack oss trayicon vorbis"
+
+DEPEND=">=virtual/python-2.4.3-r1
+ trayicon? ( >=dev-python/pygtk-2.8 )
+ mmkeys? ( >=dev-python/pygtk-2.8 )"
+
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.8
+ >=media-libs/mutagen-1.6
+ >=media-libs/gst-plugins-good-0.10.2
+ >=dev-python/gst-python-0.10.2
+ hal? ( sys-apps/hal )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.2 )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10.2
+ >=media-plugins/gst-plugins-ogg-0.10.2 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.2 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.1
+ >=dev-python/ctypes-0.9.9.6 )
+ musepack? ( >=media-plugins/gst-plugins-musepack-0.10.0
+ >=dev-python/ctypes-0.9.9.6 )
+ alsa? ( >=media-plugins/gst-plugins-alsa-0.10.2 )
+ oss? ( >=media-plugins/gst-plugins-oss-0.10.2 )
+ esd? ( >=media-plugins/gst-plugins-esd-0.10.2 )
+ gnome? ( dev-python/gnome-python-extras
+ >=media-plugins/gst-plugins-gconf-0.10.3
+ >=media-plugins/gst-plugins-gnomevfs-0.10.2
+ dev-python/feedparser )
+ dbus? ( || ( >=dev-python/dbus-python-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) ) )"
+
+PDEPEND="trayicon? ( media-plugins/quodlibet-trayicon )"
+
+pkg_setup() {
+ if use dbus && has_version '<sys-apps/dbus-0.90' && ! built_with_use sys-apps/dbus python ; then
+ eerror "dbus is missing python support. Please add 'python'"
+ eerror "to your USE flags, and re-emerge sys-apps/dbus"
+ die "dbus needs python support"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # multilib fix
+ sed -i -e "s,^TODEP = lib/quodlibet,TODEP = \$(libdir)/quodlibet," Makefile
+
+ # no gst-plugins-gconf, attempt to guess the proper pipeline value. Bug #133043, #146728.
+ if ! use gnome; then
+ local sinktype="alsasink"
+
+ use esd && sinktype="esdsink"
+ use oss && sinktype="osssink"
+ use alsa && sinktype="alsasink"
+
+ elog "Setting the default pipeline to ${sinktype}"
+
+ sed -i -e "s,^ \"pipeline\": \"\", \"pipeline\": \"${sinktype}\"," config.py
+ fi
+
+ epatch "${FILESDIR}/${P}-makefile.patch" || die "epatch failed"
+ epatch "${FILESDIR}/${P}-hal.patch"
+}
+
+src_compile() {
+ if use trayicon ; then
+ emake _trayicon.so || die "emake _trayicon.so failed"
+ fi
+
+ if use mmkeys ; then
+ emake _mmkeys.so || die "emake _mmkeys.so failed"
+ fi
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" libdir="$(get_libdir)" install || die "install failed"
+ dodoc README NEWS
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+
+ if ! use mad; then
+ elog ""
+ elog "You do not have the 'mad' USE flag enabled."
+ elog "gst-plugins-mad, which is required for mp3 playback, may"
+ elog "not be installed. For mp3 support, enable the 'mad'"
+ elog "USE flag and emerge =media-sound/${P}."
+ fi
+
+ if ! use gnome; then
+ elog ""
+ elog "You do not have the 'gnome' USE flag enabled."
+ elog "media-plugins/gst-plugins-gnomevfs may not be installed,"
+ elog "so the proper pipeline won't be automatically selected."
+ elog "We've tried to select the proper pipeline based on your"
+ elog "USE flags, but if we guessed wrong you may have to set"
+ elog "'pipeline = ' in your ~/.quodlibet/config file to one"
+ elog "of the following: alsasink, osssink, esdsink. To enable"
+ elog "automatic selection of the proper pipeline, enable the"
+ elog "'gnome' USE flag and emerge =media-sound/${P}."
+ fi
+
+ elog ""
+ elog "Installing Quod Libet from an ebuild is not supported"
+ elog "upstream. If you encounter any problems, file bugs on"
+ elog "bugs.gentoo.org. DO NOT USE THE UPSTREAM BUG SYSTEM."
+ elog ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}