summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-04 19:01:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-04 19:01:06 +0000
commit4af601b13b6c8c84c2948ec8d760817ee20a0657 (patch)
tree037c87297113a934bec7e7f6a923f3d92208185c /media-sound/qsampler
parentMasking app-i18n/man-pages-es for removal, bug #295188 (diff)
downloadgentoo-2-4af601b13b6c8c84c2948ec8d760817ee20a0657.tar.gz
gentoo-2-4af601b13b6c8c84c2948ec8d760817ee20a0657.tar.bz2
gentoo-2-4af601b13b6c8c84c2948ec8d760817ee20a0657.zip
version bump
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qsampler')
-rw-r--r--media-sound/qsampler/ChangeLog9
-rw-r--r--media-sound/qsampler/qsampler-0.2.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/media-sound/qsampler/ChangeLog b/media-sound/qsampler/ChangeLog
index 74ef08bd0776..9799e1e2037a 100644
--- a/media-sound/qsampler/ChangeLog
+++ b/media-sound/qsampler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsampler
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/ChangeLog,v 1.15 2008/07/16 22:17:44 yngwin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/ChangeLog,v 1.16 2009/12/04 19:01:06 aballier Exp $
+
+*qsampler-0.2.2 (04 Dec 2009)
+
+ 04 Dec 2009; Alexis Ballier <aballier@gentoo.org> +qsampler-0.2.2.ebuild:
+ version bump
16 Jul 2008; Ben de Groot <yngwin@gentoo.org> qsampler-0.2.1.ebuild:
Updated to split Qt4 deps
diff --git a/media-sound/qsampler/qsampler-0.2.2.ebuild b/media-sound/qsampler/qsampler-0.2.2.ebuild
new file mode 100644
index 000000000000..d551bdec8698
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsampler/qsampler-0.2.2.ebuild,v 1.1 2009/12/04 19:01:06 aballier Exp $
+
+EAPI="1"
+inherit qt4
+
+DESCRIPTION="A graphical frontend to the LinuxSampler engine"
+HOMEPAGE="http://www.linuxsampler.org"
+SRC_URI="http://download.linuxsampler.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libgig"
+
+RDEPEND="x11-libs/qt-gui:4
+ >=media-libs/liblscp-0.5.5
+ libgig? ( >=media-libs/libgig-3.2.1 )
+ >=media-sound/linuxsampler-0.5
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable libgig)
+ eqmake4 qsampler.pro -o qsampler.mak
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+ doman debian/${PN}.1
+}