summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-19 14:27:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-19 14:27:04 +0000
commitab4f49e8c6336ea94c8fbed81168d1a0ca8b68b6 (patch)
tree09178cd68f7bf9c2c4c8708f21c5754fa0f2c9c0 /media-sound/ncmpc
parentversion bump (diff)
downloadgentoo-2-ab4f49e8c6336ea94c8fbed81168d1a0ca8b68b6.tar.gz
gentoo-2-ab4f49e8c6336ea94c8fbed81168d1a0ca8b68b6.tar.bz2
gentoo-2-ab4f49e8c6336ea94c8fbed81168d1a0ca8b68b6.zip
version bump
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ncmpc')
-rw-r--r--media-sound/ncmpc/ChangeLog7
-rw-r--r--media-sound/ncmpc/ncmpc-0.20.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-sound/ncmpc/ChangeLog b/media-sound/ncmpc/ChangeLog
index d620c837f827..b2bec704b242 100644
--- a/media-sound/ncmpc/ChangeLog
+++ b/media-sound/ncmpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ncmpc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpc/ChangeLog,v 1.65 2012/01/28 14:42:21 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpc/ChangeLog,v 1.66 2012/02/19 14:27:03 aballier Exp $
+
+*ncmpc-0.20 (19 Feb 2012)
+
+ 19 Feb 2012; Alexis Ballier <aballier@gentoo.org> +ncmpc-0.20.ebuild:
+ version bump
28 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ncmpc-0.19.ebuild:
x86 stable wrt bug #400403
diff --git a/media-sound/ncmpc/ncmpc-0.20.ebuild b/media-sound/ncmpc/ncmpc-0.20.ebuild
new file mode 100644
index 000000000000..9c8627ce8aa8
--- /dev/null
+++ b/media-sound/ncmpc/ncmpc-0.20.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ncmpc/ncmpc-0.20.ebuild,v 1.1 2012/02/19 14:27:04 aballier Exp $
+
+EAPI=4
+inherit multilib
+
+DESCRIPTION="A ncurses client for the Music Player Daemon (MPD)"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Ncmpc"
+SRC_URI="http://downloads.sourceforge.net/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="artist-screen colors debug +help-screen key-screen lirc lyrics-screen mouse nls search-screen song-screen"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ >=media-libs/libmpdclient-2.2
+ sys-libs/ncurses
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS NEWS README doc/config.sample doc/keys.sample )
+
+src_configure() {
+ # upstream lirc doesn't have pkg-config file wrt #250015
+ if use lirc; then
+ export LIBLIRCCLIENT_CFLAGS="-I/usr/include/lirc"
+ export LIBLIRCCLIENT_LIBS="-llirc_client"
+ fi
+
+ # use_with lyrics-screen is for multilib
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable nls multibyte) \
+ $(use_enable nls locale) \
+ $(use_enable nls) \
+ $(use_enable colors) \
+ $(use_enable lirc) \
+ $(use_enable help-screen) \
+ $(use_enable mouse) \
+ $(use_enable artist-screen) \
+ $(use_enable search-screen) \
+ $(use_enable song-screen) \
+ $(use_enable key-screen) \
+ $(use_enable lyrics-screen) \
+ $(use_enable debug) \
+ $(use_with lyrics-screen lyrics-plugin-dir /usr/$(get_libdir)/ncmpc/lyrics)
+}