summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-09-27 11:46:27 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-09-27 11:46:27 +0000
commit0b185ee0e507e5212d5c3029cecac927170f879a (patch)
tree5cd2c080b19f847670c83d02bfcb0c1882643486 /media-sound/muse/muse-0.8.1.ebuild
parentVersion bump, ~x86 masked. Closes #29669. (diff)
downloadgentoo-2-0b185ee0e507e5212d5c3029cecac927170f879a.tar.gz
gentoo-2-0b185ee0e507e5212d5c3029cecac927170f879a.tar.bz2
gentoo-2-0b185ee0e507e5212d5c3029cecac927170f879a.zip
Version bump, ~x86 masked. Closes #29669.
Diffstat (limited to 'media-sound/muse/muse-0.8.1.ebuild')
-rw-r--r--media-sound/muse/muse-0.8.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/muse/muse-0.8.1.ebuild b/media-sound/muse/muse-0.8.1.ebuild
new file mode 100644
index 000000000000..bbd4fda813c7
--- /dev/null
+++ b/media-sound/muse/muse-0.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/muse-0.8.1.ebuild,v 1.1 2003/09/27 11:46:23 jje Exp $
+
+IUSE="ncurses oggvorbis X"
+
+S=${WORKDIR}/${P/muse/MuSE}
+
+DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
+SRC_URI="http://savannah.nongnu.org/download/muse/${P/muse/MuSE}.tar.gz"
+HOMEPAGE="http://muse.dyne.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.45-r3
+ >=media-sound/lame-3.92
+ >=sys-apps/sed-4.0.5
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ oggvorbis? ( >=media-libs/libogg-1.0 >=media-libs/libvorbis-1.0-r1 )
+ X? ( =x11-libs/gtk+-1* )"
+
+RDEPEND="virtual/glibc
+ >=media-sound/lame-3.92
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ oggvorbis? ( >=media-libs/libogg-1.0 >=media-libs/libvorbis-1.0-r1 )
+ X? ( =x11-libs/gtk+-1* )"
+
+src_compile() {
+ local xcmd
+
+ # if media-libs/{libogg,libvorbis} are installed, the configure script
+ # will automatically enable oggvorbis support
+ if ! use oggvorbis; then
+ xcmd="s:\"\$have_\(ogg\|vorbis\)\":\"no\":;"
+ fi
+
+ # if sys-libs/ncurses is installed, the configure script will
+ # automatically build the ncurses GUI
+ if ! use ncurses; then
+ xcmd="$xcmd /^GUI_RUBIK/s:true:false:"
+ fi
+
+ [ "$xcmd" ] && sed -i "$xcmd" configure
+
+ econf `use_with X x` \
+ --disable-debug
+
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
+}
+
+src_install() {
+ dobin muse
+ dodoc AUTHORS ChangeLog NEWS README TODO USAGE
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You may want to have a look at /usr/share/doc/${PF}/USAGE.gz for more info."
+ einfo
+}