summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:54:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:54:04 +0000
commit1dde9a4b108fd838d622f9b6e481b5422628c625 (patch)
tree1bd2ca0fe7317e21ef1b6550cd7f39f8110713b2 /media-sound/lame
parent$DEBUG -> use debug (diff)
downloadgentoo-2-1dde9a4b108fd838d622f9b6e481b5422628c625.tar.gz
gentoo-2-1dde9a4b108fd838d622f9b6e481b5422628c625.tar.bz2
gentoo-2-1dde9a4b108fd838d622f9b6e481b5422628c625.zip
$DEBUG -> use debug
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/lame-3.92.ebuild37
-rw-r--r--media-sound/lame/lame-3.93.1-r1.ebuild19
2 files changed, 22 insertions, 34 deletions
diff --git a/media-sound/lame/lame-3.92.ebuild b/media-sound/lame/lame-3.92.ebuild
index 9a5a67aff53b..337eac89a286 100644
--- a/media-sound/lame/lame-3.92.ebuild
+++ b/media-sound/lame/lame-3.92.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.92.ebuild,v 1.14 2003/07/18 21:43:37 tester Exp $
-
-IUSE="gtk oggvorbis"
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.92.ebuild,v 1.15 2003/08/03 02:50:40 vapier Exp $
inherit libtool
-S=${WORKDIR}/lame-${PV}
DESCRIPTION="LAME Ain't an Mp3 Encoder"
-SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
HOMEPAGE="http://www.mp3dev.org/mp3/"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="gtk debug" #oggvorbis
DEPEND="virtual/glibc
x86? ( dev-lang/nasm )
@@ -22,29 +24,22 @@ RDEPEND="virtual/glibc
gtk? ( =x11-libs/gtk+-1.2* )"
# oggvorbis? ( >=media-libs/libvorbis-1.0_rc3 )"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
-
-
src_compile() {
elibtoolize
local myconf=""
- if [ "`use oggvorbis`" ] ; then
+# if [ "`use oggvorbis`" ] ; then
# myconf="${myconf} --with-vorbis"
+# myconf="${myconf} --without-vorbis"
+# else
myconf="${myconf} --without-vorbis"
- else
- myconf="${myconf} --without-vorbis"
- fi
+# fi
if [ "`use gtk`" ] ; then
myconf="${myconf} --enable-mp3x"
fi
- if [ "${DEBUG}" ] ; then
- myconf="${myconf} --enable-debug=yes"
- else
- myconf="${myconf} --enable-debug=no"
- fi
+ use debug \
+ && myconf="${myconf} --enable-debug=yes" \
+ || myconf="${myconf} --enable-debug=no"
./configure --prefix=/usr \
--mandir=/usr/share/man \
@@ -57,8 +52,7 @@ src_compile() {
emake || die
}
-src_install () {
-
+src_install() {
make prefix=${D}/usr \
mandir=${D}/usr/share/man \
pkghtmldir=${D}/usr/share/doc/${PF}/html \
@@ -67,4 +61,3 @@ src_install () {
dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
dohtml -r ./
}
-
diff --git a/media-sound/lame/lame-3.93.1-r1.ebuild b/media-sound/lame/lame-3.93.1-r1.ebuild
index 9231a6541ae5..66bb6e719d47 100644
--- a/media-sound/lame/lame-3.93.1-r1.ebuild
+++ b/media-sound/lame/lame-3.93.1-r1.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1-r1.ebuild,v 1.6 2003/07/22 22:50:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.1-r1.ebuild,v 1.7 2003/08/03 02:50:40 vapier Exp $
inherit flag-o-matic
-IUSE="gtk"
DESCRIPTION="LAME Ain't an Mp3 Encoder"
HOMEPAGE="http://www.mp3dev.org/mp3/"
SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa"
+IUSE="gtk debug"
RDEPEND=">=sys-libs/ncurses-5.2
gtk? ( =x11-libs/gtk+-1.2* )"
-
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
@@ -34,11 +33,9 @@ src_compile() {
if [ "`use gtk`" ] ; then
myconf="${myconf} --enable-mp3x"
fi
- if [ "${DEBUG}" ] ; then
- myconf="${myconf} --enable-debug=yes"
- else
- myconf="${myconf} --enable-debug=no"
- fi
+ [ `use debug` ] \
+ && myconf="${myconf} --enable-debug=yes" \
+ || myconf="${myconf} --enable-debug=no"
econf \
--enable-shared \
@@ -50,12 +47,10 @@ src_compile() {
emake || die
}
-src_install () {
-
+src_install() {
einstall \
pkghtmldir=${D}/usr/share/doc/${PF}/html || die
dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
dohtml -r ./
}
-