summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-26 19:01:19 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-26 19:01:19 +0000
commit99300ede7726d6f857a47965770900aae2c0966d (patch)
tree90d2c786cacb972f77866ac7c539165aafd906d2 /media-sound/gmpc
parentVersion bump (diff)
downloadgentoo-2-99300ede7726d6f857a47965770900aae2c0966d.tar.gz
gentoo-2-99300ede7726d6f857a47965770900aae2c0966d.tar.bz2
gentoo-2-99300ede7726d6f857a47965770900aae2c0966d.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'media-sound/gmpc')
-rw-r--r--media-sound/gmpc/ChangeLog7
-rw-r--r--media-sound/gmpc/gmpc-0.17.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/media-sound/gmpc/ChangeLog b/media-sound/gmpc/ChangeLog
index 1e0d65b1a9bb..4352305b3169 100644
--- a/media-sound/gmpc/ChangeLog
+++ b/media-sound/gmpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/gmpc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.48 2008/12/20 16:55:14 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.49 2008/12/26 19:01:19 angelos Exp $
+
+*gmpc-0.17.0 (26 Dec 2008)
+
+ 26 Dec 2008; Christoph Mende <angelos@gentoo.org> +gmpc-0.17.0.ebuild:
+ Version bump
20 Dec 2008; nixnut <nixnut@gentoo.org> gmpc-0.16.1.ebuild:
Stable on ppc wrt bug 251332
diff --git a/media-sound/gmpc/gmpc-0.17.0.ebuild b/media-sound/gmpc/gmpc-0.17.0.ebuild
new file mode 100644
index 000000000000..97cd316cb1f2
--- /dev/null
+++ b/media-sound/gmpc/gmpc-0.17.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-0.17.0.ebuild,v 1.1 2008/12/26 19:01:19 angelos Exp $
+
+EAPI=1
+
+inherit gnome2-utils
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpcwiki.sarine.nl/index.php/GMPC"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="session"
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ dev-perl/XML-Parser
+ dev-util/gob
+ >=gnome-base/libglade-2.3
+ >=media-libs/libmpd-0.17
+ net-misc/curl
+ >=x11-libs/gtk+-2.12:2
+ x11-libs/libsexy
+ session? ( x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf \
+ $(use_enable session sm) \
+ --enable-system-libsexy
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}