summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-13 20:18:47 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-13 20:18:47 +0000
commitb6ee481161fc80837ee370b33b4c71ee93dfd08f (patch)
tree1094a38eae9faaf74c3858ed932255392532accf /media-sound/beast/beast-0.6.4.ebuild
parentFix whitespace. (diff)
downloadgentoo-2-b6ee481161fc80837ee370b33b4c71ee93dfd08f.tar.gz
gentoo-2-b6ee481161fc80837ee370b33b4c71ee93dfd08f.tar.bz2
gentoo-2-b6ee481161fc80837ee370b33b4c71ee93dfd08f.zip
new upstream version, fixes #88979. also added ~amd64 to KEYWORDS and did some cleanup, marked 0.6.4 stable on x86.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/beast/beast-0.6.4.ebuild')
-rw-r--r--media-sound/beast/beast-0.6.4.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/media-sound/beast/beast-0.6.4.ebuild b/media-sound/beast/beast-0.6.4.ebuild
index 7bcac9b6ecc6..4c0410015c4d 100644
--- a/media-sound/beast/beast-0.6.4.ebuild
+++ b/media-sound/beast/beast-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.6.4.ebuild,v 1.1 2005/02/18 21:31:42 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.6.4.ebuild,v 1.2 2005/04/13 20:18:47 luckyduck Exp $
inherit eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://beast.gtk.org"
SRC_URI="ftp://beast.gtk.org/pub/beast/v${PV%.[0-9]}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
SLOT="0"
RDEPEND=">=dev-libs/glib-2.0
@@ -30,25 +30,19 @@ DEPEND="dev-util/pkgconfig
media-libs/ladspa-sdk
${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
local myconf="--with-gnu-ld"
- use debug || myconf="${myconf} --disable-debug"
-
- use static || myconf="${myconf} --disable-static"
-
- econf ${myconf} || die "configure failed"
+ econf ${myconf} \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
- emake || die "configure failed"
+ emake || die "make failed"
}
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+ dodoc AUTHORS ChangeLog NEWS README TODO
}